summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-16 08:38:15 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-16 08:38:15 +0000
commit03e5df4503af42cfe46cff008521be1367379f57 (patch)
tree2948343d673474c4424b4f06d525d244bc355f7b /dev-libs/jrtplib/jrtplib-3.7.1.ebuild
parentApply upstream patch 20080718 correctly (#247607). (diff)
downloadgentoo-2-03e5df4503af42cfe46cff008521be1367379f57.tar.gz
gentoo-2-03e5df4503af42cfe46cff008521be1367379f57.tar.bz2
gentoo-2-03e5df4503af42cfe46cff008521be1367379f57.zip
Fixed gcc-4.3 build problem, bug #227551, thank Evil Compile Person for report and Yaroslav Gorbunov, Marek Miller for the fix.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'dev-libs/jrtplib/jrtplib-3.7.1.ebuild')
-rw-r--r--dev-libs/jrtplib/jrtplib-3.7.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/jrtplib/jrtplib-3.7.1.ebuild b/dev-libs/jrtplib/jrtplib-3.7.1.ebuild
index 2906e265d2c3..7c393d04f546 100644
--- a/dev-libs/jrtplib/jrtplib-3.7.1.ebuild
+++ b/dev-libs/jrtplib/jrtplib-3.7.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jrtplib/jrtplib-3.7.1.ebuild,v 1.1 2007/12/15 15:34:12 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jrtplib/jrtplib-3.7.1.ebuild,v 1.2 2008/12/16 08:38:15 pva Exp $
+
+inherit eutils
DESCRIPTION="JRTPLIB is an object-oriented RTP library written in C++."
HOMEPAGE="http://research.edm.luc.ac.be/jori/jrtplib/jrtplib.html"
@@ -14,6 +16,12 @@ IUSE="examples ipv6"
RDEPEND="dev-libs/jthread"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_compile() {
econf $(use_enable ipv6 IPv6)
emake || die "emake failed."