summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2011-04-11 15:50:23 +0000
committerJory Pratt <anarchy@gentoo.org>2011-04-11 15:50:23 +0000
commit1c0cfd8b34bce7da1710d3791cb037f17b3b58d3 (patch)
treec4b33aa877b22b36f205c315a7bcb57d2289fc02 /dev-libs/jemalloc
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-1c0cfd8b34bce7da1710d3791cb037f17b3b58d3.tar.gz
gentoo-2-1c0cfd8b34bce7da1710d3791cb037f17b3b58d3.tar.bz2
gentoo-2-1c0cfd8b34bce7da1710d3791cb037f17b3b58d3.zip
Do not install pprof use google-pertools instead
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/ChangeLog8
-rw-r--r--dev-libs/jemalloc/files/jemalloc-2.2.1-no-pprof.patch24
-rw-r--r--dev-libs/jemalloc/jemalloc-2.2.1-r1.ebuild (renamed from dev-libs/jemalloc/jemalloc-2.2.1.ebuild)10
-rw-r--r--dev-libs/jemalloc/metadata.xml1
4 files changed, 35 insertions, 8 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
index 2e08e88b2b39..53b57af63762 100644
--- a/dev-libs/jemalloc/ChangeLog
+++ b/dev-libs/jemalloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/jemalloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.4 2011/04/11 15:04:22 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.5 2011/04/11 15:50:23 anarchy Exp $
+
+*jemalloc-2.2.1-r1 (11 Apr 2011)
+
+ 11 Apr 2011; Jory A. Pratt <anarchy@gentoo.org> -jemalloc-2.2.1.ebuild,
+ +jemalloc-2.2.1-r1.ebuild, +files/jemalloc-2.2.1-no-pprof.patch:
+ Do not install pprof, use google-perftools instead
*jemalloc-2.2.1 (11 Apr 2011)
diff --git a/dev-libs/jemalloc/files/jemalloc-2.2.1-no-pprof.patch b/dev-libs/jemalloc/files/jemalloc-2.2.1-no-pprof.patch
new file mode 100644
index 000000000000..e10aab4d4f38
--- /dev/null
+++ b/dev-libs/jemalloc/files/jemalloc-2.2.1-no-pprof.patch
@@ -0,0 +1,24 @@
+--- a/Makefile.in 2011-04-11 10:42:32.084403330 -0500
++++ b/Makefile.in 2011-04-11 10:43:23.490760665 -0500
+@@ -42,7 +42,6 @@
+ endif
+
+ # Lists of files.
+-BINS := @srcroot@bin/pprof
+ CHDRS := @objroot@include/jemalloc/jemalloc@install_suffix@.h \
+ @objroot@include/jemalloc/jemalloc_defs@install_suffix@.h
+ CSRCS := @srcroot@src/jemalloc.c @srcroot@src/arena.c @srcroot@src/atomic.c \
+@@ -141,13 +140,6 @@
+ $(CC) -o $@ $< -L@objroot@lib -ljemalloc@install_suffix@
+ endif
+
+-install_bin:
+- install -d $(BINDIR)
+- @for b in $(BINS); do \
+- echo "install -m 755 $$b $(BINDIR)"; \
+- install -m 755 $$b $(BINDIR); \
+-done
+-
+ install_include:
+ install -d $(INCLUDEDIR)/jemalloc
+ @for h in $(CHDRS); do \
diff --git a/dev-libs/jemalloc/jemalloc-2.2.1.ebuild b/dev-libs/jemalloc/jemalloc-2.2.1-r1.ebuild
index 593c3ac9494d..67bb23a83393 100644
--- a/dev-libs/jemalloc/jemalloc-2.2.1.ebuild
+++ b/dev-libs/jemalloc/jemalloc-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-2.2.1.ebuild,v 1.1 2011/04/11 15:04:22 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-2.2.1-r1.ebuild,v 1.1 2011/04/11 15:50:23 anarchy Exp $
EAPI="2"
@@ -14,13 +14,14 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug profile stats"
+IUSE="debug stats"
DEPEND=""
RDEPEND=""
src_prepare() {
epatch "${FILESDIR}/${PN}-strip-optimization.patch"
+ epatch "${FILESDIR}/${PN}-2.2.1-no-pprof.patch"
eautoreconf
}
@@ -29,14 +30,11 @@ src_configure() {
econf \
--with-jemalloc-prefix=j \
$(use_enable debug) \
- $(use_enable profile prof) \
$(use_enable stats) \
|| die "configure failed"
}
src_install() {
make DESTDIR="${D}" install
-
- # Rename pproff to prevent collision
- mv "${D}"/usr/bin/pprof "${D}"/usr/bin/jpprof
}
+
diff --git a/dev-libs/jemalloc/metadata.xml b/dev-libs/jemalloc/metadata.xml
index 543b1a220574..a53e4b43c49d 100644
--- a/dev-libs/jemalloc/metadata.xml
+++ b/dev-libs/jemalloc/metadata.xml
@@ -6,7 +6,6 @@
Jemalloc is a general-purpose scalable concurrent allocator
</longdescription>
<use>
- <flag name='profile'>Enable allocation profiling</flag>
<flag name='stats'>Enable statistics calculation/reporting</flag>
</use>
</pkgmetadata>