summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-08-21 06:41:25 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-08-21 06:41:25 +0000
commit4eeebdbc1901caa271e3bbd7c513608e5abe4915 (patch)
tree9c9d5cf9024fd1ead7e9172e881fdc73efc555ae /dev-libs/isl
parentRespect user CFLAGS (diff)
downloadgentoo-2-4eeebdbc1901caa271e3bbd7c513608e5abe4915.tar.gz
gentoo-2-4eeebdbc1901caa271e3bbd7c513608e5abe4915.tar.bz2
gentoo-2-4eeebdbc1901caa271e3bbd7c513608e5abe4915.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/isl')
-rw-r--r--dev-libs/isl/ChangeLog8
-rw-r--r--dev-libs/isl/files/isl-0.07-gdb-autoload-dir.patch17
-rw-r--r--dev-libs/isl/isl-0.07.ebuild (renamed from dev-libs/isl/isl-0.05.1.ebuild)4
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-libs/isl/ChangeLog b/dev-libs/isl/ChangeLog
index 6d040a18389f..dba2435a9aad 100644
--- a/dev-libs/isl/ChangeLog
+++ b/dev-libs/isl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/isl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/ChangeLog,v 1.3 2011/04/13 11:03:41 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/ChangeLog,v 1.4 2011/08/21 06:41:25 dirtyepic Exp $
+
+*isl-0.07 (21 Aug 2011)
+
+ 21 Aug 2011; Ryan Hill <dirtyepic@gentoo.org> -isl-0.05.1.ebuild,
+ +isl-0.07.ebuild, +files/isl-0.07-gdb-autoload-dir.patch:
+ Version bump.
*isl-0.06 (13 Apr 2011)
diff --git a/dev-libs/isl/files/isl-0.07-gdb-autoload-dir.patch b/dev-libs/isl/files/isl-0.07-gdb-autoload-dir.patch
new file mode 100644
index 000000000000..90963692b8ea
--- /dev/null
+++ b/dev-libs/isl/files/isl-0.07-gdb-autoload-dir.patch
@@ -0,0 +1,17 @@
+Install python module into gdb auto-load directory.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -2189,9 +2189,9 @@ install-data-local: $(srcdir)/isl.py
+ case $$libisl in \
+ '') echo Cannot find isl library name. GDB bindings not installed.;; \
+ *) echo $(INSTALL_DATA) $(srcdir)/isl.py \
+- $(DESTDIR)$(libdir)/$$libisl-gdb.py; \
+- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"; \
+- $(INSTALL_DATA) $(srcdir)/isl.py $(DESTDIR)$(libdir)/$$libisl-gdb.py; esac
++ $(DESTDIR)usr/share/gdb/auto-load$(libdir)/$$libisl-gdb.py; \
++ test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)usr/share/gdb/auto-load$(libdir)"; \
++ $(INSTALL_DATA) $(srcdir)/isl.py $(DESTDIR)usr/share/gdb/auto-load$(libdir)/$$libisl-gdb.py; esac
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/dev-libs/isl/isl-0.05.1.ebuild b/dev-libs/isl/isl-0.07.ebuild
index 1900830c5376..dca00538d929 100644
--- a/dev-libs/isl/isl-0.05.1.ebuild
+++ b/dev-libs/isl/isl-0.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/isl-0.05.1.ebuild,v 1.1 2011/01/07 23:53:27 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/isl-0.07.ebuild,v 1.1 2011/08/21 06:41:25 dirtyepic Exp $
EAPI="3"
@@ -19,3 +19,5 @@ DEPEND="dev-libs/gmp"
RDEPEND="${DEPEND}"
DOCS=( ChangeLog AUTHORS doc/manual.pdf )
+PATCHES=( "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch )
+AUTOTOOLS_IN_SOURCE_BUILD="1"