summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-01-07 00:23:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-01-07 00:23:02 +0000
commitf2e8cab48e17e9b970c9c8e676997ad7181c1261 (patch)
tree68fd0118991a88b81450bd6b0b8fe8b2f136d3ad /dev-libs/isl/isl-0.11.1.ebuild
parentAdd upstream fix for print and other dialog window crash. Propagate ~sparc ke... (diff)
downloadgentoo-2-f2e8cab48e17e9b970c9c8e676997ad7181c1261.tar.gz
gentoo-2-f2e8cab48e17e9b970c9c8e676997ad7181c1261.tar.bz2
gentoo-2-f2e8cab48e17e9b970c9c8e676997ad7181c1261.zip
Version bump (bug #450632).
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'dev-libs/isl/isl-0.11.1.ebuild')
-rw-r--r--dev-libs/isl/isl-0.11.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/isl/isl-0.11.1.ebuild b/dev-libs/isl/isl-0.11.1.ebuild
new file mode 100644
index 000000000000..bd0ba8abe761
--- /dev/null
+++ b/dev-libs/isl/isl-0.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/isl-0.11.1.ebuild,v 1.1 2013/01/07 00:23:02 dirtyepic Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A library for manipulating integer points bounded by affine constraints."
+HOMEPAGE="http://www.kotnet.org/~skimo/isl/"
+SRC_URI="http://www.kotnet.org/~skimo/isl/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/gmp"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog AUTHORS doc/manual.pdf )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch
+
+ # m4/ax_create_pkgconfig_info.m4 is broken but avoid eautoreconf
+ # http://groups.google.com/group/isl-development/t/37ad876557e50f2c
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die #382737
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}