summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-01-11 02:52:47 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-01-11 02:52:47 +0000
commite66a7ad89838fda69c9fc53d360f3534ae214791 (patch)
treea8338f0cfc470535089c0cbf97ebe6a3d2ba7075 /dev-libs/iniparser
parentwhitespace (diff)
downloadgentoo-2-e66a7ad89838fda69c9fc53d360f3534ae214791.tar.gz
gentoo-2-e66a7ad89838fda69c9fc53d360f3534ae214791.tar.bz2
gentoo-2-e66a7ad89838fda69c9fc53d360f3534ae214791.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'dev-libs/iniparser')
-rw-r--r--dev-libs/iniparser/ChangeLog10
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0-autotools.patch46
-rw-r--r--dev-libs/iniparser/iniparser-3.0.0.ebuild48
3 files changed, 102 insertions, 2 deletions
diff --git a/dev-libs/iniparser/ChangeLog b/dev-libs/iniparser/ChangeLog
index e58b693a78e3..b2353a539e00 100644
--- a/dev-libs/iniparser/ChangeLog
+++ b/dev-libs/iniparser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/iniparser
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/ChangeLog,v 1.19 2010/09/26 16:58:44 leio Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/ChangeLog,v 1.20 2012/01/11 02:52:47 ottxor Exp $
+
+*iniparser-3.0.0 (11 Jan 2012)
+
+ 11 Jan 2012; Christoph Junghans <ottxor@gentoo.org> +iniparser-3.0.0.ebuild,
+ +files/iniparser-3.0-autotools.patch:
+ version bump
26 Sep 2010; Mart Raudsepp <leio@gentoo.org> iniparser-3.0b-r2.ebuild:
Add ~mips
diff --git a/dev-libs/iniparser/files/iniparser-3.0-autotools.patch b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
new file mode 100644
index 000000000000..68eca7ed601c
--- /dev/null
+++ b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
@@ -0,0 +1,46 @@
+diff --git Makefile.am Makefile.am
+new file mode 100644
+index 0000000..63ca53b
+--- /dev/null
++++ Makefile.am
+@@ -0,0 +1,10 @@
++ACLOCAL_AMFLAGS = -I config
++
++lib_LTLIBRARIES = libiniparser.la
++
++libiniparser_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libiniparser_la_SOURCES = src/dictionary.c src/iniparser.c
++
++include_HEADERS = src/dictionary.h src/iniparser.h
++
++
+diff --git configure.ac configure.ac
+new file mode 100644
+index 0000000..1eac717
+--- /dev/null
++++ configure.ac
+@@ -0,0 +1,24 @@
++AC_PREREQ([2.65])
++AC_INIT([iniparser], [3.0], [ndevilla@free.fr])
++
++AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_MACRO_DIR(config)
++
++AM_INIT_AUTOMAKE([1.8 foreign])
++
++SHARED_VERSION_INFO="0"
++AC_SUBST(SHARED_VERSION_INFO)
++
++
++# Checks for programs.
++AC_PROG_CC
++
++LT_INIT
++# Checks for header files.
++AC_CHECK_HEADERS([ ctype.h stdio.h stdlib.h string.h ])
++
++# Checks for library functions.
++AC_CHECK_FUNCS([strcmp])
++
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/dev-libs/iniparser/iniparser-3.0.0.ebuild b/dev-libs/iniparser/iniparser-3.0.0.ebuild
new file mode 100644
index 000000000000..8beb1d7fab51
--- /dev/null
+++ b/dev-libs/iniparser/iniparser-3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/iniparser-3.0.0.ebuild,v 1.1 2012/01/11 02:52:47 ottxor Exp $
+
+EAPI="4"
+
+inherit autotools-utils
+
+DESCRIPTION="A free stand-alone ini file parsing library."
+HOMEPAGE="http://ndevilla.free.fr/iniparser/"
+
+#name this version 3.0.0 instead of 3.0 as 3.0.0 > 3.0b > 3.0
+SRC_URI="http://ndevilla.free.fr/iniparser/${P%.0}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+# the tests are rather examples than tests, no point in running them
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0b-cpp.patch"
+ "${FILESDIR}/${PN}-3.0-autotools.patch"
+)
+
+AUTOTOOLS_AUTORECONF=1
+
+src_install() {
+ autotools-utils_src_install
+
+ if use doc; then
+ emake -C doc
+ dohtml -r html/*
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{c,ini,py}
+ fi
+}