summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2014-02-02 02:40:15 +0000
committerVictor Ostorga <vostorga@gentoo.org>2014-02-02 02:40:15 +0000
commit910a15316444f320d150a97abedf68183ebf787b (patch)
tree200714a0ea1eb2e75a9da7fbaac7b89cb705316f /dev-libs/iniparser
parentMore prefix keywording, and ebuild cleaning (diff)
downloadgentoo-2-910a15316444f320d150a97abedf68183ebf787b.tar.gz
gentoo-2-910a15316444f320d150a97abedf68183ebf787b.tar.bz2
gentoo-2-910a15316444f320d150a97abedf68183ebf787b.zip
Adding -r1 and restoring keywords, as it should be from the previous commit
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/iniparser')
-rw-r--r--dev-libs/iniparser/ChangeLog8
-rw-r--r--dev-libs/iniparser/iniparser-3.1-r1.ebuild47
-rw-r--r--dev-libs/iniparser/iniparser-3.1.ebuild8
3 files changed, 58 insertions, 5 deletions
diff --git a/dev-libs/iniparser/ChangeLog b/dev-libs/iniparser/ChangeLog
index 1cb92b65ce9f..97d81ec5b832 100644
--- a/dev-libs/iniparser/ChangeLog
+++ b/dev-libs/iniparser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/iniparser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/ChangeLog,v 1.32 2014/02/01 19:59:14 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/ChangeLog,v 1.33 2014/02/02 02:40:15 vostorga Exp $
+
+*iniparser-3.1-r1 (02 Feb 2014)
+
+ 02 Feb 2014; Víctor Ostorga <vostorga@gentoo.org> iniparser-3.1.ebuild,
+ +iniparser-3.1-r1.ebuild:
+ Adding -r1 and restoring keywords, as it should be from the previous commit
01 Feb 2014; Victor Ostorga iniparser-3.1.ebuild:
Adding multilib support, bug #493746 , patch thanks to Alexander Stein
diff --git a/dev-libs/iniparser/iniparser-3.1-r1.ebuild b/dev-libs/iniparser/iniparser-3.1-r1.ebuild
new file mode 100644
index 000000000000..fdcb5a6b4bca
--- /dev/null
+++ b/dev-libs/iniparser/iniparser-3.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/iniparser-3.1-r1.ebuild,v 1.1 2014/02/02 02:40:15 vostorga Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils autotools-multilib
+
+DESCRIPTION="A free stand-alone ini file parsing library."
+HOMEPAGE="http://ndevilla.free.fr/iniparser/"
+
+SRC_URI="http://ndevilla.free.fr/iniparser/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )
+ sys-devel/libtool"
+RDEPEND=""
+
+# the tests are rather examples than tests, no point in running them
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0b-cpp.patch"
+ "${FILESDIR}/${PN}-3.0-autotools.patch"
+)
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc; then
+ emake -C doc
+ dohtml -r html/*
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{c,ini,py}
+ fi
+}
diff --git a/dev-libs/iniparser/iniparser-3.1.ebuild b/dev-libs/iniparser/iniparser-3.1.ebuild
index d9252b53da20..4f22495d4634 100644
--- a/dev-libs/iniparser/iniparser-3.1.ebuild
+++ b/dev-libs/iniparser/iniparser-3.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/iniparser-3.1.ebuild,v 1.9 2014/02/01 19:59:13 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/iniparser-3.1.ebuild,v 1.10 2014/02/02 02:40:15 vostorga Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils autotools-multilib
+inherit autotools-utils
DESCRIPTION="A free stand-alone ini file parsing library."
HOMEPAGE="http://ndevilla.free.fr/iniparser/"
@@ -20,7 +20,7 @@ DEPEND="doc? ( app-doc/doxygen )
sys-devel/libtool"
RDEPEND=""
-# the tests are rather examples than tests, no point in running them
+# the tests are rather examples than tests, no point in running them
RESTRICT="test"
S="${WORKDIR}/${PN}"
@@ -33,7 +33,7 @@ PATCHES=(
)
src_install() {
- autotools-multilib_src_install
+ autotools-utils_src_install
if use doc; then
emake -C doc