summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-05 16:50:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-05 16:50:52 +0000
commitc8d3eaaa4c104e7a9d84d2e135eb2a157ff5ba97 (patch)
tree03a16319cd0795f92e23a15a8545f65ae922d9a0 /dev-libs/icu
parentAdd test to IUSE (diff)
downloadgentoo-2-c8d3eaaa4c104e7a9d84d2e135eb2a157ff5ba97.tar.gz
gentoo-2-c8d3eaaa4c104e7a9d84d2e135eb2a157ff5ba97.tar.bz2
gentoo-2-c8d3eaaa4c104e7a9d84d2e135eb2a157ff5ba97.zip
Revision bump in order to fix font-crash problem in libreoffice. Bug #381327
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog9
-rw-r--r--dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch14
-rw-r--r--dev-libs/icu/icu-4.6.1.ebuild86
-rw-r--r--dev-libs/icu/icu-4.8.1-r1.ebuild (renamed from dev-libs/icu/icu-4.8.1.ebuild)4
4 files changed, 25 insertions, 88 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index d65ca3bbd40c..e60a53b7d7ba 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.158 2011/08/20 16:00:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.159 2011/09/05 16:50:52 scarabeus Exp $
+
+*icu-4.8.1-r1 (05 Sep 2011)
+
+ 05 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> -icu-4.6.1.ebuild,
+ -icu-4.8.1.ebuild, +icu-4.8.1-r1.ebuild,
+ +files/icu-4.8.1-fix_binformat_fonts.patch:
+ Revision bump in order to fix font-crash problem in libreoffice. Bug #381327
20 Aug 2011; Jeroen Roovers <jer@gentoo.org> icu-4.8.ebuild:
Stable for HPPA (bug #374589).
diff --git a/dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch b/dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch
new file mode 100644
index 000000000000..c2e0be6c2120
--- /dev/null
+++ b/dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch
@@ -0,0 +1,14 @@
+diff -urN icu.old/source/layout/LookupProcessor.cpp icu/source/layout/LookupProcessor.cpp
+--- icu.old/source/layout/LookupProcessor.cpp 2011-09-05 18:35:11.221515458 +0200
++++ icu/source/layout/LookupProcessor.cpp 2011-09-05 18:41:30.021510913 +0200
+@@ -201,7 +201,9 @@
+
+ if (requiredFeatureIndex != 0xFFFF) {
+ requiredFeatureTable = featureListTable->getFeatureTable(requiredFeatureIndex, &requiredFeatureTag);
+- featureReferences += SWAPW(featureTable->lookupCount);
++ if (requiredFeatureTable) {
++ featureReferences += SWAPW(requiredFeatureTable->lookupCount);
++ }
+ }
+
+ lookupOrderArray = LE_NEW_ARRAY(le_uint16, featureReferences);
diff --git a/dev-libs/icu/icu-4.6.1.ebuild b/dev-libs/icu/icu-4.6.1.ebuild
deleted file mode 100644
index a3eceb3d7a84..000000000000
--- a/dev-libs/icu/icu-4.6.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.6.1.ebuild,v 1.7 2011/05/24 15:09:09 ranger Exp $
-
-EAPI="3"
-
-inherit eutils versionator
-
-MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
-MICRO_VERSION="$(get_version_component_range 3)"
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-
-BASE_URI="http://download.icu-project.org/files/icu4c/${PV}"
-DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${MAJOR_MINOR_VERSION}"
-SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
-DOCS_ARCHIVE="icu4c-${MAJOR_MINOR_VERSION//./_}-docs.zip"
-
-SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
- doc? ( ${DOCS_BASE_URI}/${DOCS_ARCHIVE} )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc examples static-libs"
-
-DEPEND="doc? ( app-arch/unzip )"
-RDEPEND=""
-
-S="${WORKDIR}/${PN}/source"
-
-QA_DT_NEEDED="/usr/lib.*/libicudata.so.${MAJOR_MINOR_VERSION/./}.${MICRO_VERSION:-0}"
-
-src_unpack() {
- unpack "${SRC_ARCHIVE}"
- if use doc; then
- mkdir docs
- pushd docs > /dev/null
- unpack "${DOCS_ARCHIVE}"
- popd > /dev/null
- fi
-}
-
-src_prepare() {
- # Do not hardcode flags into icu-config.
- # https://ssl.icu-project.org/trac/ticket/6102
- local variable
- for variable in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
- done
-
- epatch "${FILESDIR}/${P}-parallel_installation.patch"
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable examples samples) \
- $(use_enable static-libs static)
-}
-
-src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- emake -j1 check || die "emake check failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dohtml ../readme.html
- dodoc ../unicode-license.txt
- if use doc; then
- insinto /usr/share/doc/${PF}/html/api
- doins -r "${WORKDIR}/docs/"* || die "doins failed"
- fi
-}
diff --git a/dev-libs/icu/icu-4.8.1.ebuild b/dev-libs/icu/icu-4.8.1-r1.ebuild
index be7d968d4821..853df7a06d66 100644
--- a/dev-libs/icu/icu-4.8.1.ebuild
+++ b/dev-libs/icu/icu-4.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.8.1.ebuild,v 1.1 2011/07/29 15:45:27 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.8.1-r1.ebuild,v 1.1 2011/09/05 16:50:52 scarabeus Exp $
EAPI="3"
@@ -53,6 +53,8 @@ src_prepare() {
for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
done
+
+ epatch "${FILESDIR}/icu-4.8.1-fix_binformat_fonts.patch"
}
src_configure() {