summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-12-27 15:35:54 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-12-27 15:35:54 +0000
commit54eb6e559bc8f60dd883a50c7de534815bdf434d (patch)
tree6a40a602478be1bf10d2d694f0fdadd7078948b0 /dev-libs/icu
parentFix boost build wrt bug#496146 (diff)
downloadgentoo-2-54eb6e559bc8f60dd883a50c7de534815bdf434d.tar.gz
gentoo-2-54eb6e559bc8f60dd883a50c7de534815bdf434d.tar.bz2
gentoo-2-54eb6e559bc8f60dd883a50c7de534815bdf434d.zip
Remove old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog7
-rw-r--r--dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch14
-rw-r--r--dev-libs/icu/files/icu-4.8.1.1-fix_ltr.patch61
-rw-r--r--dev-libs/icu/icu-51.1-r1.ebuild125
-rw-r--r--dev-libs/icu/icu-51.1.ebuild124
5 files changed, 6 insertions, 325 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index d168a4380fb5..15e73e0240b3 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.260 2013/12/26 11:12:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.261 2013/12/27 15:35:54 dilfridge Exp $
+
+ 27 Dec 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ -files/icu-4.8.1.1-fix_ltr.patch, -files/icu-4.8.1-fix_binformat_fonts.patch,
+ -icu-51.1.ebuild, -icu-51.1-r1.ebuild:
+ Remove old
*icu-51.2-r2 (26 Dec 2013)
diff --git a/dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch b/dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch
deleted file mode 100644
index 6e1a6870baa0..000000000000
--- a/dev-libs/icu/files/icu-4.8.1-fix_binformat_fonts.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://ssl.icu-project.org/trac/ticket/8800
---- layout/LookupProcessor.cpp
-+++ layout/LookupProcessor.cpp
-@@ -201,7 +201,9 @@
-
- if (requiredFeatureIndex != 0xFFFF) {
- requiredFeatureTable = featureListTable->getFeatureTable(requiredFeatureIndex, &requiredFeatureTag);
-- featureReferences += SWAPW(featureTable->lookupCount);
-+ if (requiredFeatureTable) {
-+ featureReferences += SWAPW(requiredFeatureTable->lookupCount);
-+ }
- }
-
- lookupOrderArray = LE_NEW_ARRAY(le_uint16, featureReferences);
diff --git a/dev-libs/icu/files/icu-4.8.1.1-fix_ltr.patch b/dev-libs/icu/files/icu-4.8.1.1-fix_ltr.patch
deleted file mode 100644
index 15df6e2ddaad..000000000000
--- a/dev-libs/icu/files/icu-4.8.1.1-fix_ltr.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-https://ssl.icu-project.org/trac/ticket/8764
---- layout/LESwaps.h
-+++ layout/LESwaps.h
-@@ -45,8 +45,8 @@
- public:
-
- /**
-- * Reads a big-endian 16-bit word and returns a native-endian value.
-- * No-op on a big-endian platform, byte-swaps on a little-endian platform.
-+ * This method does the byte swap required on little endian platforms
-+ * to correctly access a (16-bit) word.
- *
- * @param value - the word to be byte swapped
- *
-@@ -56,21 +56,12 @@
- */
- static le_uint16 swapWord(le_uint16 value)
- {
--#if (defined(U_IS_BIG_ENDIAN) && U_IS_BIG_ENDIAN) || \
-- (defined(BYTE_ORDER) && defined(BIG_ENDIAN) && (BYTE_ORDER == BIG_ENDIAN)) || \
-- defined(__BIG_ENDIAN__)
-- // Fastpath when we know that the platform is big-endian.
-- return value;
--#else
-- // Reads a big-endian value on any platform.
-- const le_uint8 *p = reinterpret_cast<const le_uint8 *>(&value);
-- return (le_uint16)((p[0] << 8) | p[1]);
--#endif
-+ return (le_uint16)((value << 8) | (value >> 8));
- };
-
- /**
-- * Reads a big-endian 32-bit word and returns a native-endian value.
-- * No-op on a big-endian platform, byte-swaps on a little-endian platform.
-+ * This method does the byte swapping required on little endian platforms
-+ * to correctly access a (32-bit) long.
- *
- * @param value - the long to be byte swapped
- *
-@@ -80,16 +71,11 @@
- */
- static le_uint32 swapLong(le_uint32 value)
- {
--#if (defined(U_IS_BIG_ENDIAN) && U_IS_BIG_ENDIAN) || \
-- (defined(BYTE_ORDER) && defined(BIG_ENDIAN) && (BYTE_ORDER == BIG_ENDIAN)) || \
-- defined(__BIG_ENDIAN__)
-- // Fastpath when we know that the platform is big-endian.
-- return value;
--#else
-- // Reads a big-endian value on any platform.
-- const le_uint8 *p = reinterpret_cast<const le_uint8 *>(&value);
-- return (le_uint32)((p[0] << 24) | (p[1] << 16) | (p[2] << 8) | p[3]);
--#endif
-+ return (le_uint32)(
-+ (value << 24) |
-+ ((value << 8) & 0xff0000) |
-+ ((value >> 8) & 0xff00) |
-+ (value >> 24));
- };
-
- private:
diff --git a/dev-libs/icu/icu-51.1-r1.ebuild b/dev-libs/icu/icu-51.1-r1.ebuild
deleted file mode 100644
index 2a1e43d7b8a1..000000000000
--- a/dev-libs/icu/icu-51.1-r1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-51.1-r1.ebuild,v 1.2 2013/11/02 15:21:15 dilfridge Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs base autotools
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-
-SLOT="0/51.1"
-# As far as I can remember, icu consumers reacted rather sensitive to icu upgrades in the past.
-# Even if revdep-rebuild did not rebuild (i.e. soname did not change), random crashes and
-# other irregularities occured until the consumers were rebuilt. So let's rather err on the side
-# of caution and more rebuilds here. See also bug 464876. dilfridge
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -amd64-fbsd -x86-fbsd"
-IUSE="debug doc examples static-libs"
-
-DEPEND="
- doc? (
- app-doc/doxygen[dot]
- )
-"
-
-S="${WORKDIR}/${PN}/source"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
- "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
- "${FILESDIR}/${PN}-51.1-CVE-2013-2924.patch"
-)
-
-src_prepare() {
- local variable
-
- base_src_prepare
-
- # Do not hardcode flags in icu-config and icu-*.pc files.
- # https://ssl.icu-project.org/trac/ticket/6102
- for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed \
- -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
- -i config/icu.pc.in \
- -i config/Makefile.inc.in \
- || die
- done
-
- # Disable renaming as it is stupind thing to do
- sed -i \
- -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
- common/unicode/uconfig.h || die
-
- # Fix linking of icudata
- sed -i \
- -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
- config/mh-linux || die
-
- # Append doxygen configuration to configure
- sed -i \
- -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
- configure.in || die
- eautoreconf
-}
-
-src_configure() {
- local cross_opts
-
- # bootstrap for cross compilation
- if tc-is-cross-compiler; then
- CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
- CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
- RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
- ./configure --disable-renaming --disable-debug \
- --disable-samples --enable-static || die
- emake
- mkdir -p "${WORKDIR}/host/"
- cp -a {bin,lib,config,tools} "${WORKDIR}/host/"
- emake clean
-
- cross_opts="--with-cross-build=${WORKDIR}/host"
- fi
-
- econf \
- --disable-renaming \
- $(use_enable debug) \
- $(use_enable examples samples) \
- $(use_enable static-libs static) \
- ${cross_opts}
-}
-
-src_compile() {
- default
-
- if use doc; then
- doxygen -u Doxyfile || die
- doxygen Doxyfile || die
- fi
-}
-
-src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- emake -j1 VERBOSE="1" check
-}
-
-src_install() {
- default
-
- dohtml ../readme.html
-
- use doc && dohtml -p api -r doc/html/
-}
diff --git a/dev-libs/icu/icu-51.1.ebuild b/dev-libs/icu/icu-51.1.ebuild
deleted file mode 100644
index ec8b099c5d70..000000000000
--- a/dev-libs/icu/icu-51.1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-51.1.ebuild,v 1.14 2013/11/02 15:21:15 dilfridge Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs base autotools
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-
-SLOT="0/51.1"
-# As far as I can remember, icu consumers reacted rather sensitive to icu upgrades in the past.
-# Even if revdep-rebuild did not rebuild (i.e. soname did not change), random crashes and
-# other irregularities occured until the consumers were rebuilt. So let's rather err on the side
-# of caution and more rebuilds here. See also bug 464876. dilfridge
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 -amd64-fbsd -x86-fbsd"
-IUSE="debug doc examples static-libs"
-
-DEPEND="
- doc? (
- app-doc/doxygen[dot]
- )
-"
-
-S="${WORKDIR}/${PN}/source"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
- "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
-)
-
-src_prepare() {
- local variable
-
- base_src_prepare
-
- # Do not hardcode flags in icu-config and icu-*.pc files.
- # https://ssl.icu-project.org/trac/ticket/6102
- for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed \
- -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
- -i config/icu.pc.in \
- -i config/Makefile.inc.in \
- || die
- done
-
- # Disable renaming as it is stupind thing to do
- sed -i \
- -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
- common/unicode/uconfig.h || die
-
- # Fix linking of icudata
- sed -i \
- -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
- config/mh-linux || die
-
- # Append doxygen configuration to configure
- sed -i \
- -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
- configure.in || die
- eautoreconf
-}
-
-src_configure() {
- local cross_opts
-
- # bootstrap for cross compilation
- if tc-is-cross-compiler; then
- CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
- CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
- RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
- ./configure --disable-renaming --disable-debug \
- --disable-samples --enable-static || die
- emake
- mkdir -p "${WORKDIR}/host/"
- cp -a {bin,lib,config,tools} "${WORKDIR}/host/"
- emake clean
-
- cross_opts="--with-cross-build=${WORKDIR}/host"
- fi
-
- econf \
- --disable-renaming \
- $(use_enable debug) \
- $(use_enable examples samples) \
- $(use_enable static-libs static) \
- ${cross_opts}
-}
-
-src_compile() {
- default
-
- if use doc; then
- doxygen -u Doxyfile || die
- doxygen Doxyfile || die
- fi
-}
-
-src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- emake -j1 VERBOSE="1" check
-}
-
-src_install() {
- default
-
- dohtml ../readme.html
-
- use doc && dohtml -p api -r doc/html/
-}