summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-06-07 00:42:54 +0000
committerMike Gilbert <floppym@gentoo.org>2012-06-07 00:42:54 +0000
commit39a73b010d9e0277cfc5854919b811504d284942 (patch)
tree21797c3ade26778719eb6d22273e57b802d39ab6 /dev-libs/icu
parentDrop old per Arfrever. (diff)
downloadgentoo-2-39a73b010d9e0277cfc5854919b811504d284942.tar.gz
gentoo-2-39a73b010d9e0277cfc5854919b811504d284942.tar.bz2
gentoo-2-39a73b010d9e0277cfc5854919b811504d284942.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog7
-rw-r--r--dev-libs/icu/icu-49.1.2.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index ee5f789b763c..551cbb7eaf42 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.199 2012/06/07 00:37:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.200 2012/06/07 00:42:54 floppym Exp $
+
+*icu-49.1.2 (07 Jun 2012)
+
+ 07 Jun 2012; Mike Gilbert <floppym@gentoo.org> +icu-49.1.2.ebuild:
+ Version bump. Ebuild by Arfrever.
07 Jun 2012; Mike Gilbert <floppym@gentoo.org> -files/icu-4.8.1-fix_nan.patch,
-icu-4.8.1.1-r1.ebuild:
diff --git a/dev-libs/icu/icu-49.1.2.ebuild b/dev-libs/icu/icu-49.1.2.ebuild
new file mode 100644
index 000000000000..d0c70504b297
--- /dev/null
+++ b/dev-libs/icu/icu-49.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-49.1.2.ebuild,v 1.1 2012/06/07 00:42:54 floppym Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+MAJOR_VERSION="$(get_version_component_range 1)"
+if [[ "${PV}" =~ ^[[:digit:]]+_rc[[:digit:]]*$ ]]; then
+ MINOR_VERSION="0"
+else
+ MINOR_VERSION="$(get_version_component_range 2)"
+fi
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${PV//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}\.${MINOR_VERSION}.*"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode flags into icu-config.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ local variable
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
+ done
+
+ epatch "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
+ epatch "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
+ epatch "${FILESDIR}/${PN}-49.1.1-bsd.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"*
+ fi
+}