summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-10-25 23:15:48 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-10-25 23:15:48 +0000
commita5b1e4362a9840a2f86d16dc92ac3936921c297f (patch)
tree406181137d0938c092ac4afb6bdf0c0bd105d08d /dev-libs/ibpp/files
parent~amd64, #64772 (Manifest recommit) (diff)
downloadgentoo-2-a5b1e4362a9840a2f86d16dc92ac3936921c297f.tar.gz
gentoo-2-a5b1e4362a9840a2f86d16dc92ac3936921c297f.tar.bz2
gentoo-2-a5b1e4362a9840a2f86d16dc92ac3936921c297f.zip
Version bump. Added ~amd64
Diffstat (limited to 'dev-libs/ibpp/files')
-rw-r--r--dev-libs/ibpp/files/digest-ibpp-2.3.4.01
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.4.0-amd64.patch33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/ibpp/files/digest-ibpp-2.3.4.0 b/dev-libs/ibpp/files/digest-ibpp-2.3.4.0
new file mode 100644
index 000000000000..741df3b4e9a3
--- /dev/null
+++ b/dev-libs/ibpp/files/digest-ibpp-2.3.4.0
@@ -0,0 +1 @@
+MD5 212002f41947d6db7bf69fae5f4bfd35 ibpp-2-3-4-0-src.zip 124945
diff --git a/dev-libs/ibpp/files/ibpp-2.3.4.0-amd64.patch b/dev-libs/ibpp/files/ibpp-2.3.4.0-amd64.patch
new file mode 100644
index 000000000000..92c194e24d7c
--- /dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.4.0-amd64.patch
@@ -0,0 +1,33 @@
+diff -Naur ibpp.orig/Makefile ibpp/Makefile
+--- ibpp.orig/Makefile 2004-09-27 14:08:44.000000000 +0200
++++ ibpp/Makefile 2004-10-25 22:53:52.000000000 +0200
+@@ -164,7 +164,7 @@
+ # building on linux (any flavour, I suppose)
+ ifeq ($(PLATFORM),linux)
+ CXXOUTPUT = -o
+- CXXFLAGS =-DIBPP_LINUX
++ CXXFLAGS =-DIBPP_LINUX -fPIC
+ CXXFLAGS+=-DIBPP_GCC
+ CXXFLAGS+=-I./ -I./fbheaders
+ #
+diff -Naur ibpp.orig/array.cpp ibpp/array.cpp
+--- ibpp.orig/array.cpp 2004-09-23 17:34:08.000000000 +0200
++++ ibpp/array.cpp 2004-10-25 22:51:01.000000000 +0200
+@@ -289,7 +289,7 @@
+ throw ExceptionImpl("Array::ReadTo", "Wrong count of array elements");
+
+ IBS status;
+- long lenbuf = mBufferSize;
++ ISC_LONG lenbuf = mBufferSize;
+ (*gds.Call()->m_array_get_slice)(status.Self(), mDatabase->GetHandlePtr(),
+ mTransaction->GetHandlePtr(), &mId, &mDesc, mBuffer, &lenbuf);
+ if (status.Errors())
+@@ -1088,7 +1088,7 @@
+ }
+
+ IBS status;
+- long lenbuf = mBufferSize;
++ ISC_LONG lenbuf = mBufferSize;
+ (*gds.Call()->m_array_put_slice)(status.Self(), mDatabase->GetHandlePtr(),
+ mTransaction->GetHandlePtr(), &mId, &mDesc, mBuffer, &lenbuf);
+ if (status.Errors())