summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-03 11:33:17 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-03 11:33:17 +0000
commit08dd39a84f8be4f428e5ff57653e750c522d40b5 (patch)
treef067e679ed030deebc5f6c601ea1e8adc51c1518 /dev-libs/gtx/gtx-0.2.2.ebuild
parentAdd patch from FreeBSD-SA-12:08.linux (diff)
downloadgentoo-2-08dd39a84f8be4f428e5ff57653e750c522d40b5.tar.gz
gentoo-2-08dd39a84f8be4f428e5ff57653e750c522d40b5.tar.bz2
gentoo-2-08dd39a84f8be4f428e5ff57653e750c522d40b5.zip
dev-libs/gtx: new addition
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-libs/gtx/gtx-0.2.2.ebuild')
-rw-r--r--dev-libs/gtx/gtx-0.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/gtx/gtx-0.2.2.ebuild b/dev-libs/gtx/gtx-0.2.2.ebuild
new file mode 100644
index 000000000000..c8d7d4a5c254
--- /dev/null
+++ b/dev-libs/gtx/gtx-0.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gtx/gtx-0.2.2.ebuild,v 1.1 2012/12/03 11:33:17 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Small collection of convenience functions intended to enhance the GLib testing framework"
+HOMEPAGE="https://launchpad.net/gtx"
+SRC_URI="https://launchpad.net/gtx/trunk/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc static-libs"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docdir.patch
+ "${FILESDIR}"/${P}-debug.patch
+ "${FILESDIR}"/${P}-glib.h.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}