summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-02-14 19:34:03 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-02-14 19:34:03 +0000
commit610492aae8ea715e003177c489b2d41b633d1e6f (patch)
tree09ff46d84e9aa1ce30691d2492e3a3868fa9f242 /dev-libs/gsl
parentAdded pid in init-script. (diff)
downloadgentoo-2-610492aae8ea715e003177c489b2d41b633d1e6f.tar.gz
gentoo-2-610492aae8ea715e003177c489b2d41b633d1e6f.tar.bz2
gentoo-2-610492aae8ea715e003177c489b2d41b633d1e6f.zip
Version bump.
Diffstat (limited to 'dev-libs/gsl')
-rw-r--r--dev-libs/gsl/ChangeLog14
-rw-r--r--dev-libs/gsl/files/digest-gsl-1.31
-rw-r--r--dev-libs/gsl/gsl-1.3.ebuild43
3 files changed, 54 insertions, 4 deletions
diff --git a/dev-libs/gsl/ChangeLog b/dev-libs/gsl/ChangeLog
index 2f80bf6dbd52..842435e5ffef 100644
--- a/dev-libs/gsl/ChangeLog
+++ b/dev-libs/gsl/ChangeLog
@@ -1,16 +1,22 @@
# ChangeLog for dev-libs/gsl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/ChangeLog,v 1.6 2003/02/12 06:03:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/ChangeLog,v 1.7 2003/02/14 19:34:03 mholzer Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*gsl-1.3 (14 Feb 2003)
+
+ 14 Feb 2003; Martin Holzer <mholzer@gentoo.org> gsl-1.3.ebuild,
+ files/digest-gsl-1.3 ChangeLog :
+ Version bump. Closes #15665.
*gsl-1.2 (06 Aug 2002)
- 18 Oct 2002; George Shapovalov <george@gentoo.org> gsl-1.2.ebuild, files/k6-undef.diff :
+ 18 Oct 2002; George Shapovalov <george@gentoo.org> gsl-1.2.ebuild,
+ files/k6-undef.diff :
fix building on k6 systems. Thanks to Charles G. Waldman <cgw@alum.mit.edu>, #9011
- 06 Aug 2002; George Shapovalov <george@gentoo.org> gsl-1.2.ebuild, files/digest-gsl-1.2 :
+ 06 Aug 2002; George Shapovalov <george@gentoo.org> gsl-1.2.ebuild,
+ files/digest-gsl-1.2 :
new version, renaiming old ebuild sufficed
diff --git a/dev-libs/gsl/files/digest-gsl-1.3 b/dev-libs/gsl/files/digest-gsl-1.3
new file mode 100644
index 000000000000..31b366b486d5
--- /dev/null
+++ b/dev-libs/gsl/files/digest-gsl-1.3
@@ -0,0 +1 @@
+MD5 3696de79ad2c788871fae698e41f671b gsl-1.3.tar.gz 2052026
diff --git a/dev-libs/gsl/gsl-1.3.ebuild b/dev-libs/gsl/gsl-1.3.ebuild
new file mode 100644
index 000000000000..62badbf78402
--- /dev/null
+++ b/dev-libs/gsl/gsl-1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.3.ebuild,v 1.1 2003/02/14 19:34:03 mholzer Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU Scientific Library"
+SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
+HOMEPAGE="http://sources.redhat.com/gsl/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc"
+
+replace-flags k6-3 i586
+replace-flags k6-2 i586
+replace-flags k6 i586
+
+
+src_compile() {
+
+#Avoid locking (can break parallel builds)
+ local myconf
+ myconf="--disable-libtool-lock"
+
+ econf ${myconf} || die
+ emake || die
+
+ #Uncomment the 'make check ...' line if you want to run the test suite.
+ #Note that the check.log file will be several megabytes in size.
+ #make check > ${WORKDIR}/check.log 2>&1 || die
+
+}
+
+src_install () {
+
+ einstall || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS TODO THANKS
+
+}