summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 19:14:51 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 19:14:51 +0000
commitea3cb37d8a3095056c8257005e95a838e6ccdd0e (patch)
tree4a369afbf7bf5a4d461876354c9b6566581e7116 /dev-libs/grantlee
parentVersion bump. (diff)
downloadgentoo-2-ea3cb37d8a3095056c8257005e95a838e6ccdd0e.tar.gz
gentoo-2-ea3cb37d8a3095056c8257005e95a838e6ccdd0e.tar.bz2
gentoo-2-ea3cb37d8a3095056c8257005e95a838e6ccdd0e.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/grantlee')
-rw-r--r--dev-libs/grantlee/ChangeLog8
-rw-r--r--dev-libs/grantlee/grantlee-0.2.0.ebuild55
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-libs/grantlee/ChangeLog b/dev-libs/grantlee/ChangeLog
index 375d8725a11c..33928c0a4ef5 100644
--- a/dev-libs/grantlee/ChangeLog
+++ b/dev-libs/grantlee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/grantlee
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.13 2012/04/18 18:36:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.14 2012/08/01 19:14:51 johu Exp $
+
+*grantlee-0.2.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +grantlee-0.2.0.ebuild:
+ Version bump.
18 Apr 2012; Markus Meier <maekke@gentoo.org> grantlee-0.1.9.ebuild:
x86 stable, bug #409403
@@ -52,4 +57,3 @@
25 Apr 2011; Theo Chatzimichos <tampakrap@gentoo.org> +grantlee-0.1.7.ebuild,
+metadata.xml:
Initial commit
-
diff --git a/dev-libs/grantlee/grantlee-0.2.0.ebuild b/dev-libs/grantlee/grantlee-0.2.0.ebuild
new file mode 100644
index 000000000000..fc3fc10075ca
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-0.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.2.0.ebuild,v 1.1 2012/08/01 19:14:51 johu Exp $
+
+EAPI=4
+
+QT_MINIMAL="4.5.0"
+inherit cmake-utils
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="http://www.gitorious.org/grantlee/pages/Home"
+SRC_URI="http://www.loegria.net/grantlee/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="debug doc test"
+
+COMMON_DEPEND="
+ >=x11-libs/qt-core-${QT_MINIMAL}:4
+ >=x11-libs/qt-gui-${QT_MINIMAL}:4
+ >=x11-libs/qt-script-${QT_MINIMAL}:4
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
+ test? ( >=x11-libs/qt-test-${QT_MINIMAL}:4 )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=(AUTHORS CHANGELOG GOALS README)
+
+# Some tests fail
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.9-qt-test-optional.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${CMAKE_BUILD_DIR}/apidox/")
+
+ cmake-utils_src_install
+}