summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-31 21:58:21 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-31 21:58:21 +0000
commiteb7fe50aab5bcd2d8646427411f775982d09cbd4 (patch)
treed6298b7bcabe829f0c0936bb65f9f1687c5bb480 /dev-libs/gobject-introspection
parentDo not move py-compile so it stays executable; thanks to Ionic for reporting. (diff)
downloadgentoo-2-eb7fe50aab5bcd2d8646427411f775982d09cbd4.tar.gz
gentoo-2-eb7fe50aab5bcd2d8646427411f775982d09cbd4.tar.bz2
gentoo-2-eb7fe50aab5bcd2d8646427411f775982d09cbd4.zip
Fix py-compile idiom for automake-1.11.2 compatibility (bug #396585).
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog7
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild4
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild6
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild6
4 files changed, 14 insertions, 9 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 42c3e9f130dc..4e91d1404655 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.49 2011/12/29 17:26:19 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.50 2011/12/31 21:58:21 tetromino Exp $
+
+ 31 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gobject-introspection-0.10.8.ebuild, gobject-introspection-1.30.0.ebuild,
+ gobject-introspection-1.30.0-r1.ebuild:
+ Fix py-compile idiom for automake-1.11.2 compatibility (bug #396585).
29 Dec 2011; Pacho Ramos <pacho@gentoo.org>
gobject-introspection-1.30.0-r1.ebuild:
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild
index 65d075aaef31..8a5902ba65b8 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild,v 1.16 2011/09/20 19:53:20 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild,v 1.17 2011/12/31 21:58:21 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -41,7 +41,7 @@ src_prepare() {
use doc && MAKEOPTS="-j1"
# Don't pre-compile .py
- ln -sf $(type -P true) py-compile
+ echo '#!/bin/sh' > py-compile
# tests: build tests only on make check
epatch "${FILESDIR}/${P}-build-tests.patch"
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild
index 1bd1ae43cc1b..b048ff6546ae 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild,v 1.4 2011/12/29 17:26:19 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.30.0-r1.ebuild,v 1.5 2011/12/31 21:58:21 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -50,8 +50,8 @@ src_prepare() {
use doc && MAKEOPTS="-j1"
# Don't pre-compile .py
- ln -sf $(type -P true) py-compile
- ln -sf $(type -P true) build-aux/py-compile
+ echo '#!/bin/sh' > py-compile
+ echo '#!/bin/sh' > build-aux/py-compile
gnome2_src_prepare
}
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild
index dea653144a3a..24a5f9b1ee9c 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild,v 1.2 2011/09/28 11:20:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild,v 1.3 2011/12/31 21:58:21 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -48,8 +48,8 @@ src_prepare() {
use doc && MAKEOPTS="-j1"
# Don't pre-compile .py
- ln -sf $(type -P true) py-compile
- ln -sf $(type -P true) build-aux/py-compile
+ echo '#!/bin/sh' > py-compile
+ echo '#!/bin/sh' > build-aux/py-compile
gnome2_src_prepare
}