summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-13 16:18:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-13 16:18:49 +0000
commitc8d5063bc46b83f6cf8fbaefdf963d8d1d59e3cf (patch)
tree1bffa1946d32bdb5f66ebfe217eaa79b584b9163 /dev-libs/gobject-introspection
parentRemove old version. (diff)
downloadgentoo-2-c8d5063bc46b83f6cf8fbaefdf963d8d1d59e3cf.tar.gz
gentoo-2-c8d5063bc46b83f6cf8fbaefdf963d8d1d59e3cf.tar.bz2
gentoo-2-c8d5063bc46b83f6cf8fbaefdf963d8d1d59e3cf.zip
Version bump. More multi ABI python changes.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.9.12.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index cc40804339b9..5a89e70beef5 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.11 2010/10/02 14:06:37 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.12 2010/10/13 16:18:49 eva Exp $
+
+*gobject-introspection-0.9.12 (13 Oct 2010)
+
+ 13 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gobject-introspection-0.9.12.ebuild:
+ Version bump. More multi ABI python changes.
*gobject-introspection-0.9.10 (02 Oct 2010)
*gobject-introspection-0.9.0-r1 (02 Oct 2010)
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.9.12.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.9.12.ebuild
new file mode 100644
index 000000000000..a6eaa9af7fce
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.9.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.9.12.ebuild,v 1.1 2010/10/13 16:18:49 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+
+inherit gnome2 python
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ test? ( x11-libs/cairo )"
+
+DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable test tests)"
+
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}"usr/bin/g-ir-scanner
+ python_convert_shebangs 2 "${ED}"usr/bin/g-ir-annotation-tool
+ find "${ED}" -name "*.la" -delete || die "la files removal failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}