summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-03-18 15:22:23 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-03-18 15:22:23 +0000
commit166f741d002fc4fda7f58fa7bde8f81907b667bd (patch)
tree457888e334351edf276b2f838fb4e52970e06070 /dev-libs/gobject-introspection
parentAdding myself as maintainer since I am no longer in desktop-misc herd (diff)
downloadgentoo-2-166f741d002fc4fda7f58fa7bde8f81907b667bd.tar.gz
gentoo-2-166f741d002fc4fda7f58fa7bde8f81907b667bd.tar.bz2
gentoo-2-166f741d002fc4fda7f58fa7bde8f81907b667bd.zip
Bump to 0.6.8, all tests pass.
(Portage version: 2.1.8.1/cvs/Linux i686)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.6.8.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 3f98d64244f3..b796a045d085 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.1 2010/02/26 23:41:36 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.2 2010/03/18 15:22:23 nirbheek Exp $
+
+*gobject-introspection-0.6.8 (18 Mar 2010)
+
+ 18 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gobject-introspection-0.6.8.ebuild:
+ Bump to 0.6.8, all tests pass.
*gobject-introspection-0.6.7 (26 Feb 2010)
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.6.8.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.6.8.ebuild
new file mode 100644
index 000000000000..7dfccfe5a083
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.6.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.6.8.ebuild,v 1.1 2010/03/18 15:22:23 nirbheek Exp $
+
+EAPI="2"
+
+inherit python gnome2
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ >=dev-lang/python-2.5
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ dev-util/pkgconfig
+ sys-devel/flex"
+
+src_prepare() {
+ G2CONF="${G2CONF} --disable-static"
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner/*
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner/*
+}