summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-05-08 16:14:50 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-05-08 16:14:50 +0000
commit4a276e95c6092bdb12ac1ea58316174b544bfc4d (patch)
treeb31a4543bcc26303225740651c13d2572fda73a9 /dev-libs/gnulib/gnulib-9999.ebuild
parentVersion bump. Fixes Bug #167710, Bug #170777. (diff)
downloadgentoo-2-4a276e95c6092bdb12ac1ea58316174b544bfc4d.tar.gz
gentoo-2-4a276e95c6092bdb12ac1ea58316174b544bfc4d.tar.bz2
gentoo-2-4a276e95c6092bdb12ac1ea58316174b544bfc4d.zip
New ebuild, imported from my overlay.
Thanks to Davide Angelocola wrt bug #162295 for original ebuild. (Portage version: 2.1.2.4)
Diffstat (limited to 'dev-libs/gnulib/gnulib-9999.ebuild')
-rw-r--r--dev-libs/gnulib/gnulib-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/gnulib/gnulib-9999.ebuild b/dev-libs/gnulib/gnulib-9999.ebuild
new file mode 100644
index 000000000000..6e068988e249
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gnulib/gnulib-9999.ebuild,v 1.1 2007/05/08 16:14:50 drizzt Exp $
+
+ECVS_SERVER="cvs.savannah.gnu.org:/cvsroot/gnulib"
+ECVS_MODULE="gnulib"
+
+inherit eutils cvs
+
+DESCRIPTION="Gnulib is a library of common routines intended to be shared at the source level."
+HOMEPAGE="http://www.gnu.org/software/gnulib"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"/${PN}
+
+src_compile() {
+ emake -C doc info html || die "emake failed"
+}
+
+src_install() {
+ dodoc README COPYING ChangeLog
+ dohtml doc/gnulib.html
+ doinfo doc/gnulib.info
+
+ insinto /usr/share/${PN}
+ doins -r lib
+ doins -r m4
+ doins -r modules
+
+ # remove CVS dirs
+ find "${D}" -name CVS -type d -print0 | xargs -0 rm -r
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ make_wrapper gnulib-tool ./gnulib-tool /usr/share/${PN}
+}