summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-13 01:35:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-13 01:35:35 +0000
commit36abc87e832825236a9e5c42ed92cd89e462b812 (patch)
treeee7b5cd1915ab139c7ecfe8ba51dfbf8d47b935f /dev-libs/gmp
parentUse toolchain eclass. (Manifest recommit) (diff)
downloadgentoo-2-36abc87e832825236a9e5c42ed92cd89e462b812.tar.gz
gentoo-2-36abc87e832825236a9e5c42ed92cd89e462b812.tar.bz2
gentoo-2-36abc87e832825236a9e5c42ed92cd89e462b812.zip
x86 stable and touch up the autoconf code to only run on ppc64 #74246
Diffstat (limited to 'dev-libs/gmp')
-rw-r--r--dev-libs/gmp/gmp-4.1.4.ebuild50
1 files changed, 20 insertions, 30 deletions
diff --git a/dev-libs/gmp/gmp-4.1.4.ebuild b/dev-libs/gmp/gmp-4.1.4.ebuild
index 2fbc0b37d5ee..bba18dff2046 100644
--- a/dev-libs/gmp/gmp-4.1.4.ebuild
+++ b/dev-libs/gmp/gmp-4.1.4.ebuild
@@ -1,46 +1,47 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.4.ebuild,v 1.4 2004/11/28 11:13:49 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.4.ebuild,v 1.5 2004/12/13 01:35:35 vapier Exp $
inherit flag-o-matic libtool eutils
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
-HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
SRC_URI="mirror://gnu/gmp/${P}.tar.gz"
-RESTRICT="nomirror"
+HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
+
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ppc ~sparc mips ~alpha arm hppa ~amd64 ia64 s390 ppc64"
+KEYWORDS="~alpha ~amd64 arm hppa ia64 mips ppc ppc64 s390 ~sparc x86"
IUSE="debug"
-DEPEND="sys-apps/gawk
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ sys-apps/gawk
sys-devel/bison
sys-devel/flex
sys-devel/libtool
- sys-devel/gcc
- virtual/libc"
-
-RDEPEND="virtual/libc"
+ sys-devel/gcc"
src_unpack () {
unpack ${A}
cd ${S}
-# This patch will actually be somewhat short lived as it's really
-# somewhat of a hack. The toolchain folks (alanm) have a set of patches
-# to remove the use of the '.' form in ppc64 assembler
- use ppc64 && epatch ${FILESDIR}/ppc64-gmp-acinclude.patch
+ # This patch will actually be somewhat short lived as it's really
+ # somewhat of a hack. The toolchain folks (alanm) have a set of patches
+ # to remove the use of the '.' form in ppc64 assembler
+ if use ppc64 ; then
+ epatch ${FILESDIR}/ppc64-gmp-acinclude.patch
+ autoreconf || die
+ fi
-# fix problems for -O3 or higher; bug #66780
+ # fix problems for -O3 or higher; bug #66780
use amd64 && epatch ${FILESDIR}/amd64.patch
- autoreconf
+
+ elibtoolize
}
src_compile() {
filter-flags -ffast-math
- elibtoolize
-
local myconf=""
use sparc || myconf="--enable-mpfr"
use hppa && export CHOST="hppa-unknown-linux-gnu"
@@ -56,7 +57,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog NEWS README
dodoc doc/configuration doc/isa_abi_headache
@@ -64,16 +65,5 @@ src_install() {
}
src_test() {
-
-
- # It's pretty slow to run all the checks, and not really necessary
- # on every build of this package. Just run the checks when
- # debugging is enabled. (23 Feb 2003 agriffis)
- if use debug ; then
- emake check || die "make check failed"
- else
- # Quick partial test
- make -C tests/cxx/ check-TESTS
- fi
-
+ make check || die "make check failed"
}