summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-01-09 20:30:28 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-01-09 20:30:28 +0000
commit2cb5e05b509e793e2cb87a37cbf2aea7c7ab9264 (patch)
tree3e8f583cf8abfed969f0befd51ddbbe892be00db /dev-libs/gmp
parentnew sawfish (diff)
downloadgentoo-2-2cb5e05b509e793e2cb87a37cbf2aea7c7ab9264.tar.gz
gentoo-2-2cb5e05b509e793e2cb87a37cbf2aea7c7ab9264.tar.bz2
gentoo-2-2cb5e05b509e793e2cb87a37cbf2aea7c7ab9264.zip
new stuff
Diffstat (limited to 'dev-libs/gmp')
-rw-r--r--dev-libs/gmp/files/digest-gmp-3.1.11
-rw-r--r--dev-libs/gmp/gmp-3.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/gmp/files/digest-gmp-3.1.1 b/dev-libs/gmp/files/digest-gmp-3.1.1
new file mode 100644
index 000000000000..66dd507bf0e7
--- /dev/null
+++ b/dev-libs/gmp/files/digest-gmp-3.1.1
@@ -0,0 +1 @@
+MD5 7c25f129df145fd6f72455926e911791 gmp-3.1.1.tar.gz
diff --git a/dev-libs/gmp/gmp-3.1.1.ebuild b/dev-libs/gmp/gmp-3.1.1.ebuild
new file mode 100644
index 000000000000..4799483898f7
--- /dev/null
+++ b/dev-libs/gmp/gmp-3.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-3.1.1.ebuild,v 1.1 2001/01/09 20:30:28 drobbins Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gmp/${A}
+ ftp://prep.ai.mit.edu/gnu/gmp/${A}"
+HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --enable-mpfr --enable-mpbsd
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr install
+ prepinfo
+ dodoc AUTHORS ChangeLog COPYING* NEWS README
+ dodoc doc/assembly_code doc/configuration
+ dodoc doc/isa_abi_headache doc/multiplication
+ docinto html
+ dodoc doc/*.html
+}
+
+pkg_postinst() {
+ /usr/sbin/env-update
+}
+
+