summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-24 18:46:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-24 18:46:43 +0000
commit062e54241f09362115d6ae0842eb4fd1fdc89d19 (patch)
treecc81fd7f18a5c32db51761b35be28a09aba6857f /dev-libs/gmime
parentVersion bump. (diff)
downloadgentoo-2-062e54241f09362115d6ae0842eb4fd1fdc89d19.tar.gz
gentoo-2-062e54241f09362115d6ae0842eb4fd1fdc89d19.tar.bz2
gentoo-2-062e54241f09362115d6ae0842eb4fd1fdc89d19.zip
Version bump. Switch to EAPI=5.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/ChangeLog7
-rw-r--r--dev-libs/gmime/gmime-2.4.33.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index c642d992e1b0..e76f38f85d0a 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.212 2012/10/28 15:40:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.213 2012/11/24 18:46:43 eva Exp $
+
+*gmime-2.4.33 (24 Nov 2012)
+
+ 24 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> +gmime-2.4.33.ebuild:
+ Version bump. Switch to EAPI=5.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> gmime-2.6.10.ebuild:
ia64/sparc stable wrt #427544
diff --git a/dev-libs/gmime/gmime-2.4.33.ebuild b/dev-libs/gmime/gmime-2.4.33.ebuild
new file mode 100644
index 000000000000..cdaec68140e9
--- /dev/null
+++ b/dev-libs/gmime/gmime-2.4.33.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.33.ebuild,v 1.1 2012/11/24 18:46:43 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 eutils mono
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/"
+
+SLOT="2.4"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc mono static-libs"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ sys-libs/zlib
+ mono? (
+ dev-lang/mono
+ >=dev-dotnet/glib-sharp-2.4.0:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ mono? ( dev-dotnet/gtk-sharp-gapi:2 )
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog NEWS PORTING README TODO"
+ G2CONF="${G2CONF}
+ --enable-cryptography
+ $(use_enable mono)
+ $(use_enable static-libs static)"
+ gnome2_src_configure
+}
+
+src_compile() {
+ MONO_PATH="${S}" gnome2_src_compile
+ if use doc; then
+ emake -C docs/tutorial html
+ fi
+}
+
+src_install() {
+ GACUTIL_FLAGS="/root '${ED}/usr/$(get_libdir)' /gacdir '${EPREFIX}/usr/$(get_libdir)' /package ${PN}" \
+ gnome2_src_install
+
+ if use doc ; then
+ docinto tutorial
+ dodoc docs/tutorial/html/*
+ fi
+}