summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-03-26 18:34:04 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-03-26 18:34:04 +0000
commitd251e41767696fb916df4ccf742822825312cbd7 (patch)
tree5bff985fcdfa7f07ededa319cbf19c557c6c794b /dev-libs/glib
parentVersion bump. (diff)
downloadgentoo-2-d251e41767696fb916df4ccf742822825312cbd7.tar.gz
gentoo-2-d251e41767696fb916df4ccf742822825312cbd7.tar.bz2
gentoo-2-d251e41767696fb916df4ccf742822825312cbd7.zip
Re-add gtk-doc-am to DEPEND, bug #360581. Add changes commited to 2.26 ebuild. Drop old revisions.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/glib-2.22.5.ebuild92
-rw-r--r--dev-libs/glib/glib-2.24.1-r1.ebuild109
-rw-r--r--dev-libs/glib/glib-2.28.3.ebuild169
-rw-r--r--dev-libs/glib/glib-2.28.4.ebuild25
5 files changed, 20 insertions, 382 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 09b0830ab57c..a261ff9be90c 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.453 2011/03/22 18:51:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.454 2011/03/26 18:34:04 eva Exp $
+
+ 26 Mar 2011; Gilles Dartiguelongue <eva@gentoo.org> -glib-2.22.5.ebuild,
+ -glib-2.24.1-r1.ebuild, -glib-2.28.3.ebuild, glib-2.28.4.ebuild:
+ Re-add gtk-doc-am to DEPEND, bug #360581. Add changes commited to 2.26
+ ebuild. Drop old revisions.
22 Mar 2011; Brent Baude <ranger@gentoo.org> glib-2.26.1-r1.ebuild:
Marking glib-2.26.1-r1 ppc stable for bug 353436
diff --git a/dev-libs/glib/glib-2.22.5.ebuild b/dev-libs/glib/glib-2.22.5.ebuild
deleted file mode 100644
index 49d319d3480e..000000000000
--- a/dev-libs/glib/glib-2.22.5.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.22.5.ebuild,v 1.8 2010/09/08 20:41:23 eva Exp $
-
-EAPI="2"
-
-inherit gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam selinux xattr"
-
-RDEPEND="virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )"
-
-src_prepare() {
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- # Do not try to remove files on live filesystem, bug #XXX ?
- sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
- -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_configure() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # Always build static libs, see #153807
- # Always use internal libpcre, bug #254659
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- export XDG_CONFIG_DIRS=/etc/xdg
- export XDG_DATA_DIRS=/usr/local/share:/usr/share
- export XDG_DATA_HOME="${T}"
- emake check || die "tests failed"
-}
diff --git a/dev-libs/glib/glib-2.24.1-r1.ebuild b/dev-libs/glib/glib-2.24.1-r1.ebuild
deleted file mode 100644
index e9f5e5cc4d48..000000000000
--- a/dev-libs/glib/glib-2.24.1-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.24.1-r1.ebuild,v 1.12 2010/10/17 14:43:05 armin76 Exp $
-
-EAPI="2"
-
-inherit autotools gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam selinux xattr"
-
-RDEPEND="virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- >=dev-util/gtk-doc-am-1.13
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.13
- ~app-text/docbook-xml-dtd-4.1.2 )"
-# eautoreconf needs gtk-doc-am
-# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
-
-src_prepare() {
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- # Don't check for python, hence removing the build-time python dep.
- # We remove the gdb python scripts in src_install due to bug 291328
- epatch "${FILESDIR}/${PN}-2.24-punt-python-check.patch"
-
- # Fix test failure when upgrading from 2.22 to 2.24, upstream bug 621368
- epatch "${FILESDIR}/${PN}-2.24-assert-test-failure.patch"
-
- # Do not try to remove files on live filesystem, bug #XXX ?
- sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
- -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
-
- # Needed for the punt-python-check patch.
- # Also needed to prevent croscompile failures, see bug #267603
- eautoreconf
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_configure() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # Always build static libs, see #153807
- # Always use internal libpcre, bug #254659
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- # Don't install gdb python macros, bug 291328
- rm -rf "${D}/usr/share/gdb/" "${D}/usr/share/glib-2.0/gdb/"
-
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- export XDG_CONFIG_DIRS=/etc/xdg
- export XDG_DATA_DIRS=/usr/local/share:/usr/share
- export XDG_DATA_HOME="${T}"
- emake check || die "tests failed"
-}
diff --git a/dev-libs/glib/glib-2.28.3.ebuild b/dev-libs/glib/glib-2.28.3.ebuild
deleted file mode 100644
index 82bef5432128..000000000000
--- a/dev-libs/glib/glib-2.28.3.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.28.3.ebuild,v 1.1 2011/03/14 17:33:25 nirbheek Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit autotools gnome.org libtool eutils flag-o-matic pax-utils python virtualx
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam +introspection selinux +static-libs test xattr"
-
-RDEPEND="virtual/libiconv
- sys-libs/zlib
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.13
- ~app-text/docbook-xml-dtd-4.1.2 )
- test? ( >=sys-apps/dbus-1.2.14 )"
-PDEPEND="introspection? ( dev-libs/gobject-introspection )
- !<gnome-base/gvfs-1.6.4-r990" # Earlier versions do not work with glib
-
-# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- # Don't check for python, hence removing the build-time python dep.
- # We remove the gdb python scripts in src_install due to bug 291328
- epatch "${FILESDIR}/${PN}-2.25-punt-python-check.patch"
-
- # Fix test failure when upgrading from 2.22 to 2.24, upstream bug 621368
- epatch "${FILESDIR}/${PN}-2.24-assert-test-failure.patch"
-
- # Do not try to remove files on live filesystem, upstream bug #619274
- sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
- -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
-
- # Disable failing tests, upstream bug #???
- epatch "${FILESDIR}/${PN}-2.26.0-disable-locale-sensitive-test.patch"
- epatch "${FILESDIR}/${PN}-2.26.0-disable-volumemonitor-broken-test.patch"
-
- if ! use test; then
- # don't waste time building tests
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
- || die "sed failed"
- fi
-
- # Needed for the punt-python-check patch, disabling timeout test
- # Also needed to prevent croscompile failures, see bug #267603
- eautoreconf
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-
- epunt_cxx
-}
-
-src_configure() {
- local myconf
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- # disable-visibility needed for reference debug, bug #274647
- use debug && myconf="--enable-debug --disable-visibility"
-
- # Always use internal libpcre, bug #254659
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix
-}
-
-src_install() {
- local f
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${ED}/usr/lib/charset.alias"
-
- # Don't install gdb python macros, bug 291328
- rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
-
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
-
- insinto /usr/share/bash-completion
- for f in gdbus gsettings; do
- newins "${ED}/etc/bash_completion.d/${f}-bash-completion.sh" ${f} || die
- done
- rm -rf "${ED}/etc"
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- export XDG_CONFIG_DIRS=/etc/xdg
- export XDG_DATA_DIRS=/usr/local/share:/usr/share
- export G_DBUS_COOKIE_SHA1_KEYRING_DIR="${T}/temp"
- export XDG_DATA_HOME="${T}"
- unset GSETTINGS_BACKEND # bug 352451
-
- # Related test is a bit nitpicking
- mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
- chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
-
- # Hardened: gdb needs this, bug #338891
- if host-is-pax ; then
- pax-mark -mr "${S}"/tests/.libs/assert-msg-test \
- || die "Hardened adjustment failed"
- fi
-
- # Need X for dbus-launch session X11 initialization
- Xemake check || die "tests failed"
-}
-
-pkg_preinst() {
- # Only give the introspection message if:
- # * The user has it enabled
- # * Has glib already installed
- # * Previous version was different from new version
- if use introspection && has_version "${CATEGORY}/${PN}"; then
- if ! has_version "=${CATEGORY}/${PF}"; then
- ewarn "You must rebuild gobject-introspection so that the installed"
- ewarn "typelibs and girs are regenerated for the new APIs in glib"
- fi
- fi
-}
-
-pkg_postinst() {
- # Inform users about possible breakage when updating glib and not dbus-glib, bug #297483
- if has_version dev-libs/dbus-glib; then
- ewarn "If you experience a breakage after updating dev-libs/glib try"
- ewarn "rebuilding dev-libs/dbus-glib"
- fi
-}
diff --git a/dev-libs/glib/glib-2.28.4.ebuild b/dev-libs/glib/glib-2.28.4.ebuild
index d79467825b1b..3e9a00ea8b26 100644
--- a/dev-libs/glib/glib-2.28.4.ebuild
+++ b/dev-libs/glib/glib-2.28.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.28.4.ebuild,v 1.1 2011/03/22 00:50:05 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.28.4.ebuild,v 1.2 2011/03/26 18:34:04 eva Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -22,6 +22,7 @@ RDEPEND="virtual/libiconv
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.16
>=sys-devel/gettext-0.11
+ >=dev-util/gtk-doc-am-1.13
doc? (
>=dev-libs/libxslt-1.0
>=dev-util/gtk-doc-1.13
@@ -95,15 +96,17 @@ src_configure() {
# Always use internal libpcre, bug #254659
econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix
+ $(use_enable xattr) \
+ $(use_enable doc man) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable fam) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ --enable-regex \
+ --with-pcre=internal \
+ --with-threads=posix \
+ --disable-dtrace \
+ --disable-systemtap
}
src_install() {
@@ -135,7 +138,7 @@ src_test() {
# Related test is a bit nitpicking
mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
- chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
+ chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
# Hardened: gdb needs this, bug #338891
if host-is-pax ; then