summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-07-08 11:25:31 +0000
committerThomas Kahle <tomka@gentoo.org>2011-07-08 11:25:31 +0000
commite54de1cd396858e5fbc986d82819e5a42f2a22ac (patch)
treee15be3bcb85348c4699ab4fce0e3c8d59e1c0797 /dev-libs/gf2x
parentExport mpi wrappers again due to clash with fortran-2.eclass. Fixes bug 37443... (diff)
downloadgentoo-2-e54de1cd396858e5fbc986d82819e5a42f2a22ac.tar.gz
gentoo-2-e54de1cd396858e5fbc986d82819e5a42f2a22ac.tar.bz2
gentoo-2-e54de1cd396858e5fbc986d82819e5a42f2a22ac.zip
Adding Francois Bissey's fix for bug 366945
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'dev-libs/gf2x')
-rw-r--r--dev-libs/gf2x/ChangeLog7
-rw-r--r--dev-libs/gf2x/gf2x-1.0-r1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-libs/gf2x/ChangeLog b/dev-libs/gf2x/ChangeLog
index d14ebaaf929d..1a101f73bd8b 100644
--- a/dev-libs/gf2x/ChangeLog
+++ b/dev-libs/gf2x/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gf2x
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gf2x/ChangeLog,v 1.10 2011/05/14 09:56:27 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gf2x/ChangeLog,v 1.11 2011/07/08 11:25:31 tomka Exp $
+
+*gf2x-1.0-r1 (08 Jul 2011)
+
+ 08 Jul 2011; Thomas Kahle <tomka@gentoo.org> +gf2x-1.0-r1.ebuild:
+ Adding Francois Bissey's fix for bug 366945
*gf2x-1.0 (14 May 2011)
diff --git a/dev-libs/gf2x/gf2x-1.0-r1.ebuild b/dev-libs/gf2x/gf2x-1.0-r1.ebuild
new file mode 100644
index 000000000000..1195ef0477ad
--- /dev/null
+++ b/dev-libs/gf2x/gf2x-1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gf2x/gf2x-1.0-r1.ebuild,v 1.1 2011/07/08 11:25:31 tomka Exp $
+
+EAPI=2
+
+inherit autotools-utils
+
+PID=27999 # hack
+
+DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
+HOMEPAGE="http://gf2x.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/${PID}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+IUSE="bindist"
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ ABI=default
+ )
+
+ if use bindist ; then
+ if use x86 ; then
+ myeconfargs+=(
+ --disable-sse2
+ )
+ fi
+ if use amd64 ; then
+ myeconfargs+=(
+ --disable-pclmul
+ )
+ fi
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ dodoc ChangeLog README AUTHORS BUGS
+ autotools-utils_src_install
+}