summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-10 21:17:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-10 21:17:51 +0000
commite9415adba6bc812cb2669e5a00461fe306d18bf9 (patch)
treece1b3cbb04376a1970b0ce74ac4135f7c2ab20c2 /dev-libs/gf2x/gf2x-0.3.1.ebuild
parentMove from dev-perl to perl-core (diff)
downloadgentoo-2-e9415adba6bc812cb2669e5a00461fe306d18bf9.tar.gz
gentoo-2-e9415adba6bc812cb2669e5a00461fe306d18bf9.tar.bz2
gentoo-2-e9415adba6bc812cb2669e5a00461fe306d18bf9.zip
Initial import
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gf2x/gf2x-0.3.1.ebuild')
-rw-r--r--dev-libs/gf2x/gf2x-0.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/gf2x/gf2x-0.3.1.ebuild b/dev-libs/gf2x/gf2x-0.3.1.ebuild
new file mode 100644
index 000000000000..07d32babb376
--- /dev/null
+++ b/dev-libs/gf2x/gf2x-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gf2x/gf2x-0.3.1.ebuild,v 1.1 2009/08/10 21:17:50 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
+HOMEPAGE="http://wwwmaths.anu.edu.au/~brent/gf2x.html"
+SRC_URI="http://wwwmaths.anu.edu.au/~brent/ftp/trinom/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+# tests need gmp and ntl, introducing a circle dependency
+RESTRICT=test
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-shared.patch
+}
+
+src_compile() {
+ # turned off explicitely by upstream
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dolib.a libgf2x.a || die
+ dolib.so libgf2x.so* || die
+ dodoc Changelog README
+}