summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-12-14 21:10:49 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-12-14 21:10:49 +0000
commit3d9e20fd3db2f56cdae037c59121d26143df4c4d (patch)
tree985aaabac4ff8ddbee63489d86474de0dea5096b /dev-libs/ffcall
parentAdded amd64 keyword wrt bug #144624 (diff)
downloadgentoo-2-3d9e20fd3db2f56cdae037c59121d26143df4c4d.tar.gz
gentoo-2-3d9e20fd3db2f56cdae037c59121d26143df4c4d.tar.bz2
gentoo-2-3d9e20fd3db2f56cdae037c59121d26143df4c4d.zip
Add ~x86-fbsd keyword
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/ChangeLog5
-rw-r--r--dev-libs/ffcall/ffcall-1.10.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/ffcall/ChangeLog b/dev-libs/ffcall/ChangeLog
index 1fac4d235a1e..9e4aef3e8a5f 100644
--- a/dev-libs/ffcall/ChangeLog
+++ b/dev-libs/ffcall/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/ffcall
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ChangeLog,v 1.27 2006/08/29 13:19:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ChangeLog,v 1.28 2006/12/14 21:10:49 drizzt Exp $
+
+ 14 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> ffcall-1.10.ebuild:
+ Add ~x86-fbsd keyword
29 Aug 2006; <blubb@gentoo.org> ffcall-1.10.ebuild:
stable on amd64
diff --git a/dev-libs/ffcall/ffcall-1.10.ebuild b/dev-libs/ffcall/ffcall-1.10.ebuild
index 2d77cd3ec460..cf43344b7c7e 100644
--- a/dev-libs/ffcall/ffcall-1.10.ebuild
+++ b/dev-libs/ffcall/ffcall-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.10.ebuild,v 1.8 2006/08/29 13:19:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.10.ebuild,v 1.9 2006/12/14 21:10:49 drizzt Exp $
inherit eutils flag-o-matic
@@ -13,17 +13,18 @@ SRC_URI="ftp://ftp.santafe.edu/pub/gnu/${P}.tar.gz"
# under GNU LGPL." -ffcall author
LICENSE="|| ( GPL-2 LGPL-2 )"
SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ppc ~ppc-macos sparc x86"
+KEYWORDS="alpha amd64 ~hppa ppc ~ppc-macos sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
+RDEPEND=""
src_compile() {
# Because CHOST is set to (for example)
# alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
# doesn't work in the Makefile (29 Jan 2004 agriffis)
local cpu_setting
- [ "${ARCH}" == "alpha" ] && cpu_setting='CPU=alpha'
+ [[ "${ARCH}" == "alpha" ]] && cpu_setting='CPU=alpha'
append-flags -fPIC