summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-09 13:22:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-09 13:22:04 +0000
commit60d197bbcd8c72af413563a588282dcb05782ff0 (patch)
treefee61f4f6b171f742f4a9fede349692cd25a777d /dev-libs/expat
parentMarking eselect-ecj-0.7 ppc64 for bug 396513 (diff)
downloadgentoo-2-60d197bbcd8c72af413563a588282dcb05782ff0.tar.gz
gentoo-2-60d197bbcd8c72af413563a588282dcb05782ff0.tar.bz2
gentoo-2-60d197bbcd8c72af413563a588282dcb05782ff0.zip
Version bump wrt #407519 by Agostino Sarubbo
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/ChangeLog8
-rw-r--r--dev-libs/expat/expat-2.1.0_beta2.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 361dc006b07d..4330ce83235e 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/expat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.115 2012/03/06 21:58:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.116 2012/03/09 13:22:04 ssuominen Exp $
+
+*expat-2.1.0_beta2 (09 Mar 2012)
+
+ 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +expat-2.1.0_beta2.ebuild:
+ Version bump wrt #407519 by Agostino Sarubbo
06 Mar 2012; Brent Baude <ranger@gentoo.org> expat-2.0.1-r6.ebuild:
Marking expat-2.0.1-r6 ppc64 for bug 405915
diff --git a/dev-libs/expat/expat-2.1.0_beta2.ebuild b/dev-libs/expat/expat-2.1.0_beta2.ebuild
new file mode 100644
index 000000000000..382d955009e4
--- /dev/null
+++ b/dev-libs/expat/expat-2.1.0_beta2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.1.0_beta2.ebuild,v 1.1 2012/03/09 13:22:04 ssuominen Exp $
+
+EAPI=4
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P/_/-}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="elibc_FreeBSD examples static-libs unicode"
+
+src_unpack() {
+ if [[ ${PV} == *beta* ]]; then
+ unpack ${A}
+ mv ${PN}-* "${S}"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+
+ mkdir "${S}"-build{,u,w} || die
+}
+
+src_configure() {
+ local myconf="$(use_enable static-libs static)"
+
+ pushd "${S}"-build >/dev/null
+ ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ CFLAGS="${CFLAGS} -fshort-wchar" CPPFLAGS="${CPPFLAGS} -DXML_UNICODE_WCHAR_T" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ pushd "${S}"-build >/dev/null
+ emake
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake buildlib LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake buildlib LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ dodoc Changes README
+ dohtml doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ pushd "${S}"-build >/dev/null
+ emake install DESTDIR="${D}"
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+
+ rm -f "${ED}"usr/lib*/libexpat{,u,w}.la
+
+ # libgeom in /lib and ifconfig in /sbin require it on FreeBSD since we
+ # stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
+ use elibc_FreeBSD && gen_usr_ldscript -a expat{,u,w}
+}