summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-04-01 08:10:41 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-04-01 08:10:41 +0000
commit73f706b1f1e1452a8017055b29a92a11f6b1845e (patch)
treecc2407fb3a96249bd8b056cd1da191200485bca4 /dev-libs/eb/eb-4.2.2.ebuild
parentVersion bumped, Added ulibc patch, Bug 121463. (diff)
downloadgentoo-2-73f706b1f1e1452a8017055b29a92a11f6b1845e.tar.gz
gentoo-2-73f706b1f1e1452a8017055b29a92a11f6b1845e.tar.bz2
gentoo-2-73f706b1f1e1452a8017055b29a92a11f6b1845e.zip
Version bumped.
(Portage version: 2.0.54)
Diffstat (limited to 'dev-libs/eb/eb-4.2.2.ebuild')
-rw-r--r--dev-libs/eb/eb-4.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/eb/eb-4.2.2.ebuild b/dev-libs/eb/eb-4.2.2.ebuild
new file mode 100644
index 000000000000..8b3704bbb768
--- /dev/null
+++ b/dev-libs/eb/eb-4.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/eb-4.2.2.ebuild,v 1.1 2006/04/01 08:10:41 matsuu Exp $
+
+inherit eutils
+
+IUSE="nls ipv6 threads"
+
+DESCRIPTION="EB is a C library and utilities for accessing CD-ROM books"
+HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/eb/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/misc/eb/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+DEPEND="virtual/libc
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )"
+
+src_compile () {
+
+ econf \
+ --with-pkgdocdir=/usr/share/doc/${PF}/html \
+ `use_enable nls` \
+ `use_enable threads pthread` \
+ `use_enable ipv6` || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL* NEWS README*
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "If you are upgrading from <app-dicts/eb-4,"
+ einfo "you may need to rebuild applications depending on eb."
+ einfo
+}