summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-10-29 02:49:28 +0000
committerMamoru Komachi <usata@gentoo.org>2005-10-29 02:49:28 +0000
commit7b91dc902e2655547f46ac7330399756ac88bfe1 (patch)
tree05dcbc2e2f8e08307c449ff6d037743918e69dc2 /dev-libs/eb/eb-4.2.1.ebuild
parentNew package. (diff)
downloadgentoo-2-7b91dc902e2655547f46ac7330399756ac88bfe1.tar.gz
gentoo-2-7b91dc902e2655547f46ac7330399756ac88bfe1.tar.bz2
gentoo-2-7b91dc902e2655547f46ac7330399756ac88bfe1.zip
Version bumped.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-libs/eb/eb-4.2.1.ebuild')
-rw-r--r--dev-libs/eb/eb-4.2.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/eb/eb-4.2.1.ebuild b/dev-libs/eb/eb-4.2.1.ebuild
new file mode 100644
index 000000000000..3dea4954a6ee
--- /dev/null
+++ b/dev-libs/eb/eb-4.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/eb-4.2.1.ebuild,v 1.1 2005/10/29 02:49:28 usata Exp $
+
+inherit eutils
+
+IUSE="nls ipv6 threads"
+
+DESCRIPTION="EB is a C library and utilities for accessing CD-ROM books"
+HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/eb/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/misc/eb/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )"
+
+src_compile () {
+
+ econf \
+ --with-pkgdocdir=/usr/share/doc/${PF}/html \
+ `use_enable nls` \
+ `use_enable threads pthread` \
+ `use_enable ipv6` || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL* NEWS README*
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "If you are upgrading from <app-dicts/eb-4,"
+ einfo "you may need to rebuild applications depending on eb."
+ einfo
+}