summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-06 22:09:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-06 22:09:40 +0000
commitdbfbee35ec1489a73b7ecc50141fa1ae4277450c (patch)
tree2ad7fd56d0aef83887c2a525729c3fbec797c35c /dev-libs/dvthread/dvthread-0.13.4.ebuild
parentFix for bug 301171, ignore case patch (diff)
downloadgentoo-2-dbfbee35ec1489a73b7ecc50141fa1ae4277450c.tar.gz
gentoo-2-dbfbee35ec1489a73b7ecc50141fa1ae4277450c.tar.bz2
gentoo-2-dbfbee35ec1489a73b7ecc50141fa1ae4277450c.zip
Version bump wrt #299828, thanks to Joris Vandermeersch for reporting.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/dvthread/dvthread-0.13.4.ebuild')
-rw-r--r--dev-libs/dvthread/dvthread-0.13.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/dvthread/dvthread-0.13.4.ebuild b/dev-libs/dvthread/dvthread-0.13.4.ebuild
new file mode 100644
index 000000000000..48ac899eecea
--- /dev/null
+++ b/dev-libs/dvthread/dvthread-0.13.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.13.4.ebuild,v 1.1 2010/03/06 22:09:40 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Classes for threads and monitors, wrapped around the posix thread library"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/${PN}/download/${P}.tar.gz"
+HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/html/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-libs/dvutil-1.0.5"
+
+src_prepare() {
+ sed -i \
+ -e 's:dvthread doc m4:dvthread m4:' \
+ Makefile.in || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS
+
+ if use doc; then
+ doman doc/man/man3/*.3
+ dohtml -r doc/html/*
+ fi
+}