summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-06 02:11:30 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-06 02:11:30 +0000
commit42c85a5ee064176cdca3c8d198fce70a8409b6c9 (patch)
tree4fcf6b450539191b0c65d5fadc361ddda2b0304b /dev-libs/dmalloc/files
parentAdd extraction of "libemailfuctions" dir needed for the compilation. (Manifes... (diff)
downloadgentoo-2-42c85a5ee064176cdca3c8d198fce70a8409b6c9.tar.gz
gentoo-2-42c85a5ee064176cdca3c8d198fce70a8409b6c9.tar.bz2
gentoo-2-42c85a5ee064176cdca3c8d198fce70a8409b6c9.zip
Fix sigsegv on ppc when sandbox is enabled for bug 80928; thanks to Wormo for the patch.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-libs/dmalloc/files')
-rw-r--r--dev-libs/dmalloc/files/dmalloc-5.4.2-sandbox.patch102
1 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/dmalloc/files/dmalloc-5.4.2-sandbox.patch b/dev-libs/dmalloc/files/dmalloc-5.4.2-sandbox.patch
new file mode 100644
index 000000000000..ea3a8eb3602e
--- /dev/null
+++ b/dev-libs/dmalloc/files/dmalloc-5.4.2-sandbox.patch
@@ -0,0 +1,102 @@
+diff -Naur dmalloc-5.4.2.orig/configure dmalloc-5.4.2/configure
+--- dmalloc-5.4.2.orig/configure 2005-02-04 17:33:49.922306392 -0800
++++ dmalloc-5.4.2/configure 2005-02-04 17:59:03.332233112 -0800
+@@ -5443,7 +5443,7 @@
+ heap_p += size;
+ return pnt;
+ }
+-char *calloc (int number, int size) {
++static char *calloc (int number, int size) {
+ char *start, *pnt, *end;
+ if (main_b) _exit(0);
+ /* it should be already 0s */
+@@ -5453,7 +5453,7 @@
+ while (pnt < end) { *pnt++ = '\0'; }
+ return start;
+ }
+-char *realloc (char *old_pnt, int new_size) {
++static char *realloc (char *old_pnt, int new_size) {
+ char *start, *pnt, *end;
+ if (main_b) _exit(0);
+ start = malloc (new_size);
+@@ -5717,14 +5717,14 @@
+ static char heap_mem[102400], *heap_p = heap_mem;
+ free (char *pnt) {
+ }
+-char *malloc (int size) {
++static char *malloc (int size) {
+ char *pnt;
+ getenv("PATH");
+ pnt = heap_p;
+ heap_p += size;
+ return pnt;
+ }
+-char *calloc (int number, int size) {
++static char *calloc (int number, int size) {
+ char *start, *pnt, *end;
+ getenv("PATH");
+ /* it should be already 0s */
+@@ -5734,7 +5734,7 @@
+ while (pnt < end) { *pnt++ = '\0'; }
+ return start;
+ }
+-char *realloc (char *old_pnt, int new_size) {
++static char *realloc (char *old_pnt, int new_size) {
+ char *start, *pnt, *end;
+ getenv("PATH");
+ start = malloc (new_size);
+diff -Naur dmalloc-5.4.2.orig/configure.ac dmalloc-5.4.2/configure.ac
+--- dmalloc-5.4.2.orig/configure.ac 2005-02-04 17:54:41.131093744 -0800
++++ dmalloc-5.4.2/configure.ac 2005-02-04 16:36:10.5.4.25872 -0800
+@@ -330,14 +330,14 @@
+ static int main_b = 0;
+ static char heap_mem[102400], *heap_p = heap_mem;
+ free () { if (main_b) _exit(0); }
+-char *malloc (int size) {
++static char *malloc (int size) {
+ char *pnt;
+ if (main_b) _exit(0);
+ pnt = heap_p;
+ heap_p += size;
+ return pnt;
+ }
+-char *calloc (int number, int size) {
++static char *calloc (int number, int size) {
+ char *start, *pnt, *end;
+ if (main_b) _exit(0);
+ /* it should be already 0s */
+@@ -347,7 +347,7 @@
+ while (pnt < end) { *pnt++ = '\0'; }
+ return start;
+ }
+-char *realloc (char *old_pnt, int new_size) {
++static char *realloc (char *old_pnt, int new_size) {
+ char *start, *pnt, *end;
+ if (main_b) _exit(0);
+ start = malloc (new_size);
+@@ -388,14 +388,14 @@
+ static char heap_mem[102400], *heap_p = heap_mem;
+ free (char *pnt) {
+ }
+-char *malloc (int size) {
++static char *malloc (int size) {
+ char *pnt;
+ getenv("PATH");
+ pnt = heap_p;
+ heap_p += size;
+ return pnt;
+ }
+-char *calloc (int number, int size) {
++static char *calloc (int number, int size) {
+ char *start, *pnt, *end;
+ getenv("PATH");
+ /* it should be already 0s */
+@@ -405,7 +405,7 @@
+ while (pnt < end) { *pnt++ = '\0'; }
+ return start;
+ }
+-char *realloc (char *old_pnt, int new_size) {
++static char *realloc (char *old_pnt, int new_size) {
+ char *start, *pnt, *end;
+ getenv("PATH");
+ start = malloc (new_size);