summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-03 11:36:15 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-03 11:36:15 +0000
commitfa3d5d29518b4ed5f533819b0cad220132e21151 (patch)
treec8dcd0edae7986c08f9b7b75cf51132c0c6ce670 /dev-libs/dee
parentVersion bump (diff)
downloadgentoo-2-fa3d5d29518b4ed5f533819b0cad220132e21151.tar.gz
gentoo-2-fa3d5d29518b4ed5f533819b0cad220132e21151.tar.bz2
gentoo-2-fa3d5d29518b4ed5f533819b0cad220132e21151.zip
dev-libs/dee: Version BUmp; add py3.4 support, #531122; add missing dependency, #508592
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-libs/dee')
-rw-r--r--dev-libs/dee/ChangeLog8
-rw-r--r--dev-libs/dee/dee-1.0.14-r2.ebuild9
-rw-r--r--dev-libs/dee/dee-1.2.7.ebuild93
3 files changed, 106 insertions, 4 deletions
diff --git a/dev-libs/dee/ChangeLog b/dev-libs/dee/ChangeLog
index 5f23d558015e..4968c75fee36 100644
--- a/dev-libs/dee/ChangeLog
+++ b/dev-libs/dee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/dee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/ChangeLog,v 1.24 2014/10/25 10:43:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/ChangeLog,v 1.25 2014/12/03 11:36:15 jlec Exp $
+
+*dee-1.2.7 (03 Dec 2014)
+
+ 03 Dec 2014; Justin Lecher <jlec@gentoo.org> dee-1.0.14-r2.ebuild,
+ +dee-1.2.7.ebuild:
+ Version BUmp; add py3.4 support, #531122; add missing dependency, #508592
25 Oct 2014; Pacho Ramos <pacho@gentoo.org> -dee-1.0.14-r1.ebuild,
-dee-1.0.14.ebuild:
diff --git a/dev-libs/dee/dee-1.0.14-r2.ebuild b/dev-libs/dee/dee-1.0.14-r2.ebuild
index 378937bcc47b..c70af8ab2ca9 100644
--- a/dev-libs/dee/dee-1.0.14-r2.ebuild
+++ b/dev-libs/dee/dee-1.0.14-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/dee-1.0.14-r2.ebuild,v 1.8 2013/12/08 20:00:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/dee-1.0.14-r2.ebuild,v 1.9 2014/12/03 11:36:15 jlec Exp $
EAPI=5
@@ -24,7 +24,10 @@ REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
dev-libs/glib:2
dev-libs/icu:=
- introspection? ( ${PYTHON_DEPS} )"
+ introspection? (
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ )"
DEPEND="${RDEPEND}
$(vala_depend)
doc? ( dev-util/gtk-doc )
diff --git a/dev-libs/dee/dee-1.2.7.ebuild b/dev-libs/dee/dee-1.2.7.ebuild
new file mode 100644
index 000000000000..cbe93f45c92d
--- /dev/null
+++ b/dev-libs/dee/dee-1.2.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dee/dee-1.2.7.ebuild,v 1.1 2014/12/03 11:36:15 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+AUTOTOOLS_AUTORECONF=y
+
+inherit autotools-utils vala python-r1
+
+DESCRIPTION="Provide objects allowing to create Model-View-Controller type programs across DBus"
+HOMEPAGE="https://launchpad.net/dee/"
+SRC_URI="https://launchpad.net/dee/1.0/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc debug examples +icu introspection static-libs test"
+
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/icu:=
+ introspection? (
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-libs/gtx
+ dev-util/dbus-test-runner
+ )"
+
+src_prepare() {
+ sed \
+ -e '/GCC_FLAGS/s:-g::' \
+ -e 's:vapigen:${VAPIGEN}:g' \
+ -i configure.ac || die
+
+ sed \
+ -e 's:bindings::g' \
+ -i Makefile.am || die
+
+ vala_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug trace-log)
+ $(use_enable doc gtk-doc)
+ $(use_enable icu)
+ $(use_enable test tests)
+# $(use_enable test extended-tests)
+ )
+ autotools-utils_src_configure
+ use introspection && python_copy_sources
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ compilation() {
+ cd bindings || die
+ emake \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ use introspection && python_foreach_impl run_in_build_dir compilation
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PN}/
+ doins -r examples
+ fi
+
+ installation() {
+ cd bindings || die
+ emake \
+ PYGI_OVERRIDES_DIR="$(python_get_sitedir)"/gi/overrides \
+ DESTDIR="${D}" \
+ install
+ }
+ use introspection && python_foreach_impl run_in_build_dir installation
+}