summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-23 22:27:11 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-23 22:27:11 +0000
commit31ad68a739f5bb57b6a216a68a025589bed326f4 (patch)
treec1a8013ea442ed63c20b4e0bc508d4644df2b6f7 /dev-libs/dbus-glib
parentAdd >=obex-data-server-0.4 to net-wireless/bluez mask. Fixes bug #249315. (diff)
downloadgentoo-2-31ad68a739f5bb57b6a216a68a025589bed326f4.tar.gz
gentoo-2-31ad68a739f5bb57b6a216a68a025589bed326f4.tar.bz2
gentoo-2-31ad68a739f5bb57b6a216a68a025589bed326f4.zip
version bump. ebuild from Santiago M. Mola <coldwind@gentoo.org> with additional changes for fixing tests and correcting depends by me
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r7 x86_64)
Diffstat (limited to 'dev-libs/dbus-glib')
-rw-r--r--dev-libs/dbus-glib/ChangeLog9
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.78.ebuild70
-rw-r--r--dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch12
3 files changed, 90 insertions, 1 deletions
diff --git a/dev-libs/dbus-glib/ChangeLog b/dev-libs/dbus-glib/ChangeLog
index fe4c3930eb09..36eb4f0e1fbc 100644
--- a/dev-libs/dbus-glib/ChangeLog
+++ b/dev-libs/dbus-glib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/dbus-glib
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/ChangeLog,v 1.42 2008/12/15 20:30:30 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/ChangeLog,v 1.43 2008/12/23 22:27:07 cardoe Exp $
+
+*dbus-glib-0.78 (23 Dec 2008)
+
+ 23 Dec 2008; Doug Goldstein <cardoe@gentoo.org>
+ +files/dbus-glib-0.78-as-needed.patch, +dbus-glib-0.78.ebuild:
+ version bump. ebuild from Santiago M. Mola <coldwind@gentoo.org> with
+ additional changes for fixing tests and correcting depends by me
15 Dec 2008; Tobias Klausmann <klausman@gentoo.org> dbus-glib-0.76.ebuild:
Stable on alpha, bug #250289
diff --git a/dev-libs/dbus-glib/dbus-glib-0.78.ebuild b/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
new file mode 100644
index 000000000000..dd98252e6acf
--- /dev/null
+++ b/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.78.ebuild,v 1.1 2008/12/23 22:27:08 cardoe Exp $
+
+inherit eutils multilib autotools bash-completion
+
+DESCRIPTION="D-Bus bindings for glib"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bash-completion debug doc selinux test"
+
+RDEPEND=">=sys-apps/dbus-1.1.0
+ >=dev-libs/glib-2.10
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/expat-1.95.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen app-text/xmlto )"
+
+BASH_COMPLETION_NAME="dbus"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-introspection.patch
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable bash-completion) \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug checks) \
+ $(use_enable debug asserts) \
+ $(use_enable test tests) \
+ $(use_with test test-socket-dir ${T}/dbus-test-socket) \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+
+ #FIXME: We need --with-bash-completion-dir
+ if use bash-completion ; then
+ dobashcompletion "${D}"/etc/profile.d/dbus-bash-completion.sh
+ rm -rf "${D}"/etc/profile.d
+ fi
+}
diff --git a/dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch b/dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch
new file mode 100644
index 000000000000..01b92968f03e
--- /dev/null
+++ b/dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch
@@ -0,0 +1,12 @@
+diff -ur dbus-glib-0.78.orig/dbus/Makefile.am dbus-glib-0.78/dbus/Makefile.am
+--- dbus-glib-0.78.orig/dbus/Makefile.am 2008-12-23 15:55:22.000000000 +0100
++++ dbus-glib-0.78/dbus/Makefile.am 2008-12-23 15:55:57.000000000 +0100
+@@ -104,7 +104,7 @@
+
+ dbus_bash_completion_helper_SOURCES = \
+ dbus-bash-completion-helper.c
+-dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) -lexpat libdbus-gtool.la libdbus-glib-1.la
++dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) libdbus-gtool.la libdbus-glib-1.la -lexpat
+
+
+ EXTRA_DIST=dbus-gmarshal.list make-dbus-glib-error-switch.sh make-dbus-glib-error-enum.sh dbus-bash-completion.sh.in