summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-01-12 07:34:48 +0000
committerEray Aslan <eras@gentoo.org>2012-01-12 07:34:48 +0000
commit281f402121a07959246a0171de1d9918ba17c45f (patch)
tree2071e06a62b361de2a1faea0f05c07ddf5e88ecb /dev-libs/cyrus-sasl
parentVersion bump. (diff)
downloadgentoo-2-281f402121a07959246a0171de1d9918ba17c45f.tar.gz
gentoo-2-281f402121a07959246a0171de1d9918ba17c45f.tar.bz2
gentoo-2-281f402121a07959246a0171de1d9918ba17c45f.zip
fix PLAIN and LOGIN with no auxprop - bug #392761
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog8
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r1.ebuild215
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-auxprop.patch16
3 files changed, 238 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 13ecfbb565c0..0d40b3caf922 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.240 2012/01/04 22:04:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.241 2012/01/12 07:34:48 eras Exp $
+
+*cyrus-sasl-2.1.25-r1 (12 Jan 2012)
+
+ 12 Jan 2012; Eray Aslan <eras@gentoo.org> +cyrus-sasl-2.1.25-r1.ebuild,
+ +files/cyrus-sasl-2.1.25-auxprop.patch:
+ fix PLAIN and LOGIN with no auxprop - bug #392761
04 Jan 2012; Brent Baude <ranger@gentoo.org> cyrus-sasl-2.1.23-r6.ebuild:
Marking cyrus-sasl-2.1.23-r6 ppc for bug 393387
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r1.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r1.ebuild
new file mode 100644
index 000000000000..4d4b299aaca2
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r1.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r1.ebuild,v 1.1 2012/01/12 07:34:48 eras Exp $
+
+EAPI=4
+inherit eutils flag-o-matic multilib autotools pam java-pkg-opt-2 db-use
+
+SASLAUTHD_CONF_VER="2.1.21"
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)."
+HOMEPAGE="http://cyrusimap.web.cmu.edu/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-sasl/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="authdaemond berkdb gdbm kerberos ldapdb openldap mysql pam postgres sample sqlite
+srp ssl static-libs urandom"
+
+DEPEND="authdaemond? ( || ( net-mail/courier-imap mail-mta/courier ) )
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ kerberos? ( virtual/krb5 )
+ openldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? ( dev-libs/openssl )
+ java? ( >=virtual/jdk-1.4 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sasldb_al.patch
+ epatch "${FILESDIR}"/${P}-saslauthd_libtool.patch
+ epatch "${FILESDIR}"/${P}-avoid_pic_overwrite.patch
+ epatch "${FILESDIR}"/${P}-autotools_fixes.patch
+ epatch "${FILESDIR}"/${P}-as_needed.patch
+ epatch "${FILESDIR}"/${P}-missing_header.patch
+ epatch "${FILESDIR}"/${P}-gssapi.patch
+ epatch "${FILESDIR}"/${P}-lib_before_plugin.patch
+ epatch "${FILESDIR}"/${P}-fix_heimdal.patch
+ epatch "${FILESDIR}"/${P}-auxprop.patch
+ epatch "${FILESDIR}"/${PN}-2.1.23-gss_c_nt_hostbased_service.patch
+ epatch "${FILESDIR}"/${PN}-2.1.23+db-5.0.patch
+# epatch "${FILESDIR}"/${P}-fix_dovecot_authentication.patch
+
+ # Use plugindir for sasldir
+ sed -i '/^sasldir =/s:=.*:= $(plugindir):' \
+ "${S}"/plugins/Makefile.{am,in} || die "sed failed"
+
+ AT_M4DIR="${S}/cmulocal ${S}/config" eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ append-cppflags -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D_BSD_SOURCE -DLDAP_DEPRECATED
+
+ # Java support.
+ use java && export JAVAC="${JAVAC} ${JAVACFLAGS}"
+
+ local myconf
+
+ # Add authdaemond support (bug #56523).
+ if use authdaemond ; then
+ myconf="${myconf} --with-authdaemond=/var/lib/courier/authdaemon/socket"
+ fi
+
+ # Fix for bug #59634.
+ if ! use ssl ; then
+ myconf="${myconf} --without-des"
+ fi
+
+ if use mysql || use postgres ; then
+ myconf="${myconf} --enable-sql"
+ else
+ myconf="${myconf} --disable-sql"
+ fi
+
+ # Default to GDBM if both 'gdbm' and 'berkdb' are present.
+ if use gdbm ; then
+ einfo "Building with GNU DB as database backend for your SASLdb"
+ myconf="${myconf} --with-dblib=gdbm"
+ elif use berkdb ; then
+ einfo "Building with BerkeleyDB as database backend for your SASLdb"
+ myconf="${myconf} --with-dblib=berkeley --with-bdb-incdir=$(db_includedir)"
+ else
+ einfo "Building without SASLdb support"
+ myconf="${myconf} --with-dblib=none"
+ fi
+
+ # Use /dev/urandom instead of /dev/random (bug #46038).
+ if use urandom ; then
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ fi
+
+ econf \
+ --enable-login \
+ --enable-ntlm \
+ --enable-auth-sasldb \
+ --disable-cmulocal \
+ --disable-krb4 \
+ --enable-otp \
+ --without-sqlite \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-plugindir=/usr/$(get_libdir)/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ $(use_with ssl openssl) \
+ $(use_with pam) \
+ $(use_with openldap ldap) \
+ $(use_enable ldapdb) \
+ $(use_enable sample) \
+ $(use_enable kerberos gssapi) \
+ $(use_enable java) \
+ $(use_with java javahome ${JAVA_HOME}) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3 /usr/$(get_libdir)) \
+ $(use_enable srp) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ # Default location for java classes breaks OpenOffice (bug #60769).
+ # Thanks to axxo@gentoo.org for the solution.
+ cd "${S}"
+ if use java ; then
+ jar -cvf ${PN}.jar -C java $(find java -name "*.class")
+ fi
+
+ # Add testsaslauthd (bug #58768).
+ cd "${S}/saslauthd"
+ emake testsaslauthd
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/sasl2 /etc/sasl2
+
+ if use sample ; then
+ docinto sample
+ dodoc sample/*.c
+ exeinto /usr/share/doc/${P}/sample
+ doexe sample/client sample/server
+ fi
+
+ # Default location for java classes breaks OpenOffice (bug #60769).
+ if use java ; then
+ java-pkg_dojar ${PN}.jar
+ java-pkg_regso "${D}/usr/$(get_libdir)/libjavasasl.so"
+ # hackish, don't wanna dig through makefile
+ rm -Rf "${D}/usr/$(get_libdir)/java"
+ docinto "java"
+ dodoc "${S}/java/README" "${FILESDIR}/java.README.gentoo" "${S}"/java/doc/*
+ dodir "/usr/share/doc/${PF}/java/Test"
+ insinto "/usr/share/doc/${PF}/java/Test"
+ doins "${S}"/java/Test/*.java
+ fi
+
+ docinto ""
+ dodoc AUTHORS ChangeLog NEWS README doc/TODO doc/*.txt
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*.html
+
+ docinto "saslauthd"
+ dodoc saslauthd/{AUTHORS,ChangeLog,LDAP_SASLAUTHD,NEWS,README}
+
+ newpamd "${FILESDIR}/saslauthd.pam-include" saslauthd
+
+ newinitd "${FILESDIR}/pwcheck.rc6" pwcheck
+
+ newinitd "${FILESDIR}/saslauthd2.rc6" saslauthd
+ newconfd "${FILESDIR}/saslauthd-${SASLAUTHD_CONF_VER}.conf" saslauthd
+
+ newsbin "${S}/saslauthd/testsaslauthd" testsaslauthd
+
+ use static-libs || find "${D}"/usr/lib*/sasl2 -name 'lib*.la' -delete
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libsasl2.so.2.0.23
+}
+
+pkg_postinst () {
+ # Generate an empty sasldb2 with correct permissions.
+ if ( use berkdb || use gdbm ) && [[ ! -f "${ROOT}/etc/sasl2/sasldb2" ]] ; then
+ einfo "Generating an empty sasldb2 with correct permissions ..."
+ echo "p" | "${ROOT}/usr/sbin/saslpasswd2" -f "${ROOT}/etc/sasl2/sasldb2" -p login \
+ || die "Failed to generate sasldb2"
+ "${ROOT}/usr/sbin/saslpasswd2" -f "${ROOT}/etc/sasl2/sasldb2" -d login \
+ || die "Failed to delete temp user"
+ chown root:mail "${ROOT}/etc/sasl2/sasldb2" \
+ || die "Failed to chown ${ROOT}/etc/sasl2/sasldb2"
+ chmod 0640 "${ROOT}/etc/sasl2/sasldb2" \
+ || die "Failed to chmod ${ROOT}/etc/sasl2/sasldb2"
+ fi
+
+ if use authdaemond ; then
+ elog "You need to add a user running a service using Courier's"
+ elog "authdaemon to the 'mail' group. For example, do:"
+ elog " gpasswd -a postfix mail"
+ elog "to add the 'postfix' user to the 'mail' group."
+ fi
+
+ preserve_old_lib_notify /usr/$(get_libdir)/libsasl2.so.2.0.23
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-auxprop.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-auxprop.patch
new file mode 100644
index 000000000000..a9dd1476d2e6
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-auxprop.patch
@@ -0,0 +1,16 @@
+https://bugzilla.cyrusimap.org/show_bug.cgi?id=3590
+https://bugs.gentoo.org/show_bug.cgi?id=392761
+
+--- cyrus-sasl-2.1.25/lib/auxprop.c~ 2011-10-20 17:33:46.423015318 +0200
++++ cyrus-sasl-2.1.25/lib/auxprop.c 2011-10-20 17:48:49.336348654 +0200
+@@ -971,6 +971,10 @@
+ }
+
+ if(!found) {
++ /* compatibility with <= 2.1.23, ignore the lack of auxrop plugin */
++ if (!plist)
++ result = SASL_OK;
++ else
+ _sasl_log(sparams->utils->conn, SASL_LOG_DEBUG,
+ "could not find auxprop plugin, was searching for '%s'",
+ plist ? plist : "[all]");