summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-10-29 21:58:22 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-10-29 21:58:22 +0000
commit246fabf54ed443e976eb467da828f17fa898d548 (patch)
tree956f7853b1720a00938abe70c04a17fe0668f61b /dev-libs/cyrus-sasl
parentVersion bump. Fixes bug #150587. Uses generation 2 and adds support for the e... (diff)
downloadgentoo-2-246fabf54ed443e976eb467da828f17fa898d548.tar.gz
gentoo-2-246fabf54ed443e976eb467da828f17fa898d548.tar.bz2
gentoo-2-246fabf54ed443e976eb467da828f17fa898d548.zip
Fix for bug #152544. Thanks to everybody that helped there.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog8
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.22-r1.ebuild266
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-crypt.patch74
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22-r16
4 files changed, 353 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 0fa572fd8dec..b33114824e59 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.162 2006/10/23 10:00:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.163 2006/10/29 21:58:22 ferdy Exp $
+
+*cyrus-sasl-2.1.22-r1 (29 Oct 2006)
+
+ 29 Oct 2006; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/cyrus-sasl-2.1.22-crypt.patch, +cyrus-sasl-2.1.22-r1.ebuild:
+ Fix for bug #152544. Thanks to everybody that helped there.
23 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
cyrus-sasl-2.1.22.ebuild:
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22-r1.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22-r1.ebuild
new file mode 100644
index 000000000000..ad41ecccecc4
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22-r1.ebuild
@@ -0,0 +1,266 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22-r1.ebuild,v 1.1 2006/10/29 21:58:22 ferdy Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.7.9"
+
+inherit eutils gnuconfig flag-o-matic java-pkg multilib autotools
+
+ntlm_patch=${P}-ntlm_impl-spnego.patch.gz
+SASLAUTHD_CONF_VER=2.1.21
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/sasl/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz
+ ntlm_unsupported_patch? ( mirror://gentoo/${ntlm_patch} )"
+
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+# Removed 'static' USE flag because it is broken upstream, Bug #94137
+IUSE="berkdb crypt gdbm ldap mysql postgres kerberos ssl java pam authdaemond sample urandom srp ntlm_unsupported_patch"
+
+RDEPEND="berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ pam? ( virtual/pam )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ kerberos? ( virtual/krb5 )
+ authdaemond? (
+ || (
+ >=net-mail/courier-imap-3.0.7
+ >=mail-mta/courier-0.46
+ )
+ )
+ java? ( =virtual/jdk-1.4* )
+ ntlm_unsupported_patch? ( >=net-fs/samba-3.0.9 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+
+ use java && java-pkg_pkg_setup
+
+ if use gdbm && use berkdb; then
+ echo
+ ewarn "You have both \"gdbm\" and \"berkdb\" in your USE flags."
+ ewarn "Will default to GNU DB as your SASLdb database backend."
+ ewarn "If you want to build with Berkeley DB support; hit Control-C now."
+ ewarn "Change your USE flag -gdbm and emerge again."
+ echo
+ has_version ">=sys-apps/portage-2.0.50" && (
+ einfo "It would be best practice to add the set of USE flags that you use for this"
+ einfo "package to the file: /etc/portage/package.use. Example:"
+ einfo "\`echo \"dev-libs/cyrus-sasl -gdbm berkdb\" >> /etc/portage/package.use\`"
+ einfo "to build cyrus-sasl with Berkeley database as your SASLdb backend."
+ )
+ echo
+ ewarn "Waiting 10 seconds before starting..."
+ ewarn "(Control-C to abort)..."
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+
+ # Fix default port name for rimap auth mechanism.
+ sed -e '/define DEFAULT_REMOTE_SERVICE/s:imap:imap2:' \
+ -i saslauthd/auth_rimap.c || die "sed failed"
+
+ # Fixed upstream. Add openldap 2.3 compile patch - bug #113914
+ # epatch "${FILESDIR}/${PN}-2.1.21-configure.patch"
+
+ # Fixed upstream. Add configdir support.
+ # epatch "${FILESDIR}/${PN}-2.1.20-configdir.patch"
+
+ # Fix include path for newer PostgreSQL versions.
+ epatch "${FILESDIR}/${PN}-2.1.17-pgsql-include.patch"
+
+ # Fixed upstream. Fix for gcc-4.0
+ # epatch "${FILESDIR}/${PN}-2.1.20-gcc4.patch"
+
+ # UNSUPPORTED ntlm patch. Bug #81342
+ use ntlm_unsupported_patch && epatch "${DISTDIR}/${ntlm_patch}"
+
+ # --as-needed.
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # Support for crypted passwords. Bug #45181
+ use crypt && epatch "${FILESDIR}/cyrus-sasl-2.1.19-checkpw.c.patch"
+
+ # Upstream doesn't even honor their own configure options... grumble
+ sed -i 's:^sasldir = .*$:sasldir = $(plugindir):' "${S}"/plugins/Makefile.{am,in}
+
+ # Fixes for bug #152544
+ epatch "${FILESDIR}/${P}-crypt.patch"
+
+ # Recreate configure.
+ cd "${S}"
+ rm "${S}/config/libtool.m4"
+ AT_M4DIR="${S}/cmulocal ${S}/config" eautoreconf
+}
+
+src_compile() {
+ local myconf="--enable-login --enable-ntlm --enable-auth-sasldb --disable-krb4 --disable-otp"
+# myconf="${myconf} `use_enable static`" -- doesn't work upstream Bug #94137
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with pam`"
+ myconf="${myconf} `use_with ldap`"
+ myconf="${myconf} `use_enable ldap ldapdb`"
+ myconf="${myconf} `use_enable sample`"
+ myconf="${myconf} `use_enable kerberos gssapi`"
+ myconf="${myconf} `use_with mysql` `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ use postgres && myconf="${myconf} `use_with postgres pgsql $(pg_config --libdir)`"
+
+ # Add use srp. Bug #81970.
+ myconf="${myconf} `use_enable srp`"
+ myconf="${myconf} `use_enable java` `use_with java javahome ${JAVA_HOME}`"
+ # bug #56523. add authdaemond support.
+ myconf="${myconf} `use_with authdaemond`"
+
+ # fix for bug #59634. langthang 20040810.
+ if ! use ssl; then
+ myconf="${myconf} --without-des"
+ fi
+
+ if use mysql || use postgres ; then
+ myconf="${myconf} --enable-sql"
+ else
+ myconf="${myconf} --disable-sql"
+ fi
+
+ # default to GDBM if both 'gdbm' and 'berkdb' present.
+ if use gdbm; then
+ einfo "build with GNU DB as database backend for your SASLdb."
+ myconf="${myconf} --with-dblib=gdbm"
+ elif use berkdb ; then
+ einfo "build with Berkeley DB as database backend for your SASLdb."
+ myconf="${myconf} --with-dblib=berkeley"
+ else
+ einfo "build without SASLdb support"
+ myconf="${myconf} --with-dblib=none"
+ fi
+
+ # Use /dev/urandom instead of /dev/random. Bug #46038
+ use urandom && myconf="${myconf} --with-devrandom=/dev/urandom"
+
+ # Detect mips systems properly.
+ gnuconfig_update
+
+ econf \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-plugindir=/usr/$(get_libdir)/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ ${myconf} || die "econf failed"
+
+ # Upstream doesn't even honor their own configure options... grumble
+ # We sed'd Makefile.in already. Remove this block after testing period.
+ # sed -i 's:^sasldir = .*$:sasldir = $(plugindir):' ${S}/plugins/Makefile
+
+ # we force -j1 for bug #110066
+ emake -j1 || die "compile problem"
+
+ # Bug #60769. Default location for java classes breaks OpenOffice.
+ # Thanks to axxo@gentoo.org for the solution.
+ cd "${S}"
+ if use java; then
+ jar -cvf ${PN}.jar -C java $(find java -name "*.class")
+ fi
+
+ # Bug #58768. Add testsaslauthd.
+ cd "${S}/saslauthd"
+ emake testsaslauthd || die "failed to make"
+}
+
+src_install () {
+ #einstall
+ make DESTDIR=${D} install || die "failed to install."
+ keepdir /var/lib/sasl2 /etc/sasl2
+
+ # Install everything necessary so user can build sample client/server
+ # (bug #64733)
+ if use sample; then
+ insinto /usr/share/${PN}-2/examples
+ doins aclocal.m4 config.h config.status configure.in
+ dosym /usr/include/sasl /usr/share/${PN}-2/examples/include
+ exeinto /usr/share/${PN}-2/examples
+ doexe libtool
+ insinto /usr/share/${PN}-2/examples/sample
+ doins sample/*.{c,h} sample/*Makefile*
+ insinto /usr/share/${PN}-2/examples/sample/.deps
+ doins sample/.deps/*
+ dodir /usr/share/${PN}-2/examples/lib
+ dosym /usr/$(get_libdir)/libsasl2.la /usr/share/${PN}-2/examples/lib/libsasl2.la
+ dodir /usr/share/${PN}-2/examples/lib/.libs
+ dosym /usr/$(get_libdir)/libsasl2.so /usr/share/${PN}-2/examples/lib/.libs/libsasl2.so
+ fi
+
+ # Bug #60769. Default location for java classes breaks OpenOffice.
+ if use java; then
+ java-pkg_dojar ${PN}.jar
+ #hackish, don't wanna dig though makefile
+ rm -rf "${D}/usr/$(get_libdir)/java"
+ docinto java
+ dodoc "${S}/java/README" "${FILESDIR}/java.README.gentoo" "${S}"/java/doc/*
+ mkdir "${D}/usr/share/doc/${PF}/java/Test/" \
+ || die "failed to create ${D}/usr/share/doc/${PF}/java/Test/"
+ cp "${S}"/java/Test/*.java "${D}/usr/share/doc/${PF}/java/Test/" \
+ || die "failed to copy java files to ${D}/usr/share/doc/${PF}/java/Test/"
+ fi
+
+ docinto ""
+ dodoc AUTHORS COPYING ChangeLog NEWS README doc/TODO doc/*.txt
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*.html
+
+ docinto saslauthd
+ dodoc saslauthd/{AUTHORS,COPYING,ChangeLog,LDAP_SASLAUTHD,NEWS,README}
+
+ newpamd "${FILESDIR}/saslauthd.pam-include" saslauthd
+ newinitd "${FILESDIR}/pwcheck.rc6" pwcheck || \
+ die "failed to install pwcheck to /etc/init.d"
+ newinitd "${FILESDIR}/saslauthd2.rc6" saslauthd || \
+ die "failed to install saslauthd to /etc/init.d"
+ newconfd "${FILESDIR}/saslauthd-${SASLAUTHD_CONF_VER}.conf" saslauthd || \
+ die "failed to install /etc/conf.d/saslauthd"
+
+ exeinto "${ROOT}/usr/sbin"
+ newexe "${S}/saslauthd/testsaslauthd" testsaslauthd || \
+ die "failed to install testsaslauthd."
+}
+
+pkg_postinst () {
+ # Generate an empty sasldb2 with correct permissions.
+ if ( use berkdb || use gdbm ) && [[ ! -f "${ROOT}/etc/sasl2/sasldb2" ]]; then
+ einfo "Generate an empty sasldb2 with correct permissions."
+ echo "p" | "${ROOT}/usr/sbin/saslpasswd2" -f "${ROOT}/etc/sasl2/sasldb2" -p login \
+ || die "failed to generate sasldb2"
+ "${ROOT}/usr/sbin/saslpasswd2" -f "${ROOT}/etc/sasl2/sasldb2" -d login \
+ || die "failed to delete temp user"
+ chown root:mail "${ROOT}/etc/sasl2/sasldb2" \
+ || die "failed to chown ${ROOT}/etc/sasl2/sasldb2"
+ chmod 0640 "${ROOT}/etc/sasl2/sasldb2" \
+ || die "failed to chmod ${ROOT}/etc/sasl2/sasldb2"
+ fi
+
+ if use sample; then
+ einfo "You have chosen to install sources for example client and server."
+ einfo "To build these, please type:"
+ einfo "\tcd /usr/share/${PN}-2/examples/sample && make"
+ fi
+
+ if use authdaemond; then
+ ewarn "You need to add a user running a service using Courier's"
+ ewarn "authdaemon to the 'mail' group. For example, do:"
+ echo " gpasswd -a postfix mail"
+ ewarn "to add postfix to 'mail' group."
+ fi
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-crypt.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-crypt.patch
new file mode 100644
index 000000000000..8ac468794462
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-crypt.patch
@@ -0,0 +1,74 @@
+diff -urpN cyrus-sasl-2.1.22-orig/lib/Makefile.am cyrus-sasl-2.1.22/lib/Makefile.am
+--- cyrus-sasl-2.1.22-orig/lib/Makefile.am 2006-05-17 16:46:13.000000000 +0000
++++ cyrus-sasl-2.1.22/lib/Makefile.am 2006-10-24 15:20:36.000000000 +0000
+@@ -45,6 +45,7 @@ sasl_version = 2:22:0
+
+ INCLUDES=-I$(top_srcdir)/include -I$(top_srcdir)/plugins -I$(top_builddir)/include -I$(top_srcdir)/sasldb
+
++AM_CFLAGS = -fPIC
+ EXTRA_DIST = windlopen.c staticopen.h NTMakefile
+ EXTRA_LIBRARIES = libsasl2.a
+ noinst_LIBRARIES = @SASL_STATIC_LIBS@
+diff -urpN cyrus-sasl-2.1.22-orig/plugins/Makefile.am cyrus-sasl-2.1.22/plugins/Makefile.am
+--- cyrus-sasl-2.1.22-orig/plugins/Makefile.am 2006-05-17 16:46:16.000000000 +0000
++++ cyrus-sasl-2.1.22/plugins/Makefile.am 2006-10-24 15:19:38.000000000 +0000
+@@ -63,6 +63,7 @@ srp_version = 2:22:0
+
+ INCLUDES=-I$(top_srcdir)/include -I$(top_srcdir)/lib -I$(top_srcdir)/sasldb -I$(top_builddir)/include
+ AM_LDFLAGS = -module -export-dynamic -rpath $(plugindir)
++AM_CFLAGS = -fPIC
+
+ COMPAT_OBJS = @LTGETADDRINFOOBJS@ @LTGETNAMEINFOOBJS@ @LTSNPRINTFOBJS@
+
+diff -urpN cyrus-sasl-2.1.22-orig/sasldb/Makefile.am cyrus-sasl-2.1.22/sasldb/Makefile.am
+--- cyrus-sasl-2.1.22-orig/sasldb/Makefile.am 2006-05-17 16:46:17.000000000 +0000
++++ cyrus-sasl-2.1.22/sasldb/Makefile.am 2006-10-24 15:20:10.000000000 +0000
+@@ -48,6 +48,7 @@ INCLUDES=-I$(top_srcdir)/include -I$(top
+
+ extra_common_sources = db_none.c db_ndbm.c db_gdbm.c db_berkeley.c
+
++AM_CFLAGS = -fPIC
+ EXTRA_DIST = NTMakefile
+
+ noinst_LTLIBRARIES = libsasldb.la
+diff -urpN cyrus-sasl-2.1.22-orig/utils/Makefile.am cyrus-sasl-2.1.22/utils/Makefile.am
+--- cyrus-sasl-2.1.22-orig/utils/Makefile.am 2006-05-18 18:34:26.000000000 +0000
++++ cyrus-sasl-2.1.22/utils/Makefile.am 2006-10-24 15:12:39.000000000 +0000
+@@ -42,7 +42,7 @@
+ #
+ ################################################################
+
+-all_sasl_libs = ../lib/libsasl2.la $(SASL_DB_LIB) $(LIB_SOCKET)
++all_sasl_libs = ../lib/libsasl2.la $(SASL_DB_LIB) $(LIB_SOCKET) $(LIB_CRYPT)
+ all_sasl_static_libs = ../lib/.libs/libsasl2.a $(SASL_DB_LIB) $(LIB_SOCKET) $(GSSAPIBASE_LIBS) $(GSSAPI_LIBS) $(SASL_KRB_LIB) $(LIB_DES) $(PLAIN_LIBS) $(SRP_LIBS) $(LIB_MYSQL) $(LIB_PGSQL) $(LIB_SQLITE)
+
+ sbin_PROGRAMS = @SASL_DB_UTILS@ @SMTPTEST_PROGRAM@ pluginviewer
+diff -urpN cyrus-sasl-2.1.22-orig/sample/Makefile.am cyrus-sasl-2.1.22/sample/Makefile.am
+--- cyrus-sasl-2.1.22-orig/sample/Makefile.am 2004-03-10 15:44:55.000000000 +0000
++++ cyrus-sasl-2.1.22/sample/Makefile.am 2006-10-24 16:03:22.000000000 +0000
+@@ -54,10 +54,10 @@ sample_server_SOURCES = sample-server.c
+ server_SOURCES = server.c common.c common.h
+ client_SOURCES = client.c common.c common.h
+
+-server_LDADD = ../lib/libsasl2.la $(LIB_SOCKET)
+-client_LDADD = ../lib/libsasl2.la $(LIB_SOCKET)
++server_LDADD = ../lib/libsasl2.la $(LIB_SOCKET) $(LIB_CRYPT)
++client_LDADD = ../lib/libsasl2.la $(LIB_SOCKET) $(LIB_CRYPT)
+
+-sample_client_LDADD = ../lib/libsasl2.la $(LIB_SOCKET)
+-sample_server_LDADD = ../lib/libsasl2.la $(LIB_SOCKET)
++sample_client_LDADD = ../lib/libsasl2.la $(LIB_SOCKET) $(LIB_CRYPT)
++sample_server_LDADD = ../lib/libsasl2.la $(LIB_SOCKET) $(LIB_CRYPT)
+
+ EXTRA_DIST = NTMakefile
+--- cyrus-sasl-2.1.22-orig/lib/Makefile.am 2006-10-24 16:51:41.000000000 +0000
++++ cyrus-sasl-2.1.22/lib/Makefile.am 2006-10-24 16:51:10.000000000 +0000
+@@ -63,7 +63,7 @@ lib_LTLIBRARIES = libsasl2.la
+ libsasl2_la_SOURCES = $(common_sources) $(common_headers)
+ libsasl2_la_LDFLAGS = -version-info $(sasl_version)
+ libsasl2_la_DEPENDENCIES = $(LTLIBOBJS)
+-libsasl2_la_LIBADD = $(LTLIBOBJS) $(SASL_DL_LIB) $(LIB_SOCKET) $(LIB_DOOR)
++libsasl2_la_LIBADD = $(LTLIBOBJS) $(SASL_DL_LIB) $(LIB_SOCKET) $(LIB_DOOR) $(LIB_CRYPT)
+
+ if MACOSX
+ framedir = /Library/Frameworks/SASL2.framework
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22-r1 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22-r1
new file mode 100644
index 000000000000..5b2ad91fb88b
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22-r1
@@ -0,0 +1,6 @@
+MD5 2e039a5b53e8934a3ca7107808acd7e1 cyrus-sasl-2.1.22-ntlm_impl-spnego.patch.gz 7466
+RMD160 70e498d2ca27289bd729563793dcdabe650ffac4 cyrus-sasl-2.1.22-ntlm_impl-spnego.patch.gz 7466
+SHA256 a696dddc27d46ab1950b546fcf49efc1a03a8380ecc4537d085d8daacb88ccf0 cyrus-sasl-2.1.22-ntlm_impl-spnego.patch.gz 7466
+MD5 45dde9d19193ae9dd388eb68b2027bc9 cyrus-sasl-2.1.22.tar.gz 1609278
+RMD160 086e20d01588cb86decad001244b72a37223354c cyrus-sasl-2.1.22.tar.gz 1609278
+SHA256 c69e3853f35b14ee2c3f6e876e42d880927258ff4678aa052e5f0853db209962 cyrus-sasl-2.1.22.tar.gz 1609278