summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-27 20:52:44 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-27 20:52:44 +0000
commitb2698b82f82fd071e188fc04e675426e35cd0aa9 (patch)
tree020a902eb2c442d122c71103ccb0fa85b3a87e7d /dev-libs/crystalspace
parentmoved to dev-libs (diff)
downloadgentoo-2-b2698b82f82fd071e188fc04e675426e35cd0aa9.tar.gz
gentoo-2-b2698b82f82fd071e188fc04e675426e35cd0aa9.tar.bz2
gentoo-2-b2698b82f82fd071e188fc04e675426e35cd0aa9.zip
moved/touchedup
Diffstat (limited to 'dev-libs/crystalspace')
-rw-r--r--dev-libs/crystalspace/ChangeLog21
-rw-r--r--dev-libs/crystalspace/crystalspace-20030413-r1.ebuild53
-rw-r--r--dev-libs/crystalspace/files/digest-crystalspace-20030413-r11
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/crystalspace/ChangeLog b/dev-libs/crystalspace/ChangeLog
new file mode 100644
index 000000000000..b8e1dbd5a06e
--- /dev/null
+++ b/dev-libs/crystalspace/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for media-libs/crystalspace
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crystalspace/ChangeLog,v 1.1 2003/04/27 20:51:37 vapier Exp $
+
+*crystalspace-20030413-r1 (17 Apr 2003)
+
+ 17 Apr 2003; Philip Walls <malverian@gentoo.org>
+ crystalspace-20030413-r1.ebuild :
+ Fixed problem with env.d/15crystalspace (vars now on seperate lines)
+
+*crystalspace-20030413 (13 Apr 2003)
+
+ 13 Apr 2003; Philip Walls <malverian@gentoo.org>
+ crystalspace-20030413.ebuild :
+ CrystalSpace snapshot that works with Planeshift
+
+*crystalspace-0.96_p002 (02 Apr 2003)
+
+ 02 Apr 2003; Philip Walls <malverian@gentoo.org>
+ crystalspace-0.96_p002.ebuild :
+ Initial import. Thanks to lu_zero for testing and original ebuild.
diff --git a/dev-libs/crystalspace/crystalspace-20030413-r1.ebuild b/dev-libs/crystalspace/crystalspace-20030413-r1.ebuild
new file mode 100644
index 000000000000..f0db6730efe0
--- /dev/null
+++ b/dev-libs/crystalspace/crystalspace-20030413-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crystalspace/crystalspace-20030413-r1.ebuild,v 1.1 2003/04/27 20:51:37 vapier Exp $
+
+inherit games
+
+DESCRIPTION="portable 3D Game Development Kit written in C++"
+SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
+HOMEPAGE="http://crystal.sourceforge.net/"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+IUSE="oggvorbis mikmod openal freetype 3ds mng"
+
+DEPEND=">=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ mng? ( media-libs/libmng )
+ mikmod? ( media-libs/libmikmod )
+ 3ds? ( media-libs/lib3ds )
+ freetype? ( >=media-libs/freetype-2.0 )
+ openal? ( media-libs/openal )
+ zlib? ( sys-libs/zlib )
+ oggvorbis? ( >=media-libs/libogg-1.0 )
+ >=media-libs/libvorbis-1.0 )
+ x86? ( dev-lang/nasm )
+ dev-libs/ode
+ >=dev-lang/perl-5.6.1
+ !dev-libs/crystalspace-cvs"
+
+S=${WORKDIR}/CS
+
+CRYSTAL_PREFIX=${GAMES_PREFIX_OPT}/crystal
+
+src_compile() {
+ ./configure --prefix=${CRYSTAL_PREFIX} || die
+ make all || die
+}
+
+src_install() {
+ dodir ${CRYSTAL_PREFIX}
+ make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
+
+ insinto /etc/env.d
+ echo "CRYSTAL=${CRYSTAL_PREFIX}" > ${T}/90crystalspace
+ echo "CEL=${CRYSTAL_PREFIX}" >> ${T}/90crystalspace
+ doins ${T}/90crystalspace
+
+ dodir ${GAMES_BINDIR}
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config ${GAMES_BINDIR}/cs-config
+
+ prepgamesdirs
+}
diff --git a/dev-libs/crystalspace/files/digest-crystalspace-20030413-r1 b/dev-libs/crystalspace/files/digest-crystalspace-20030413-r1
new file mode 100644
index 000000000000..76ed9c7b75de
--- /dev/null
+++ b/dev-libs/crystalspace/files/digest-crystalspace-20030413-r1
@@ -0,0 +1 @@
+MD5 4f1791a51d929ff14766e596b0a80841 crystalspace-20030413.tar.gz 17033685