summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 18:05:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 18:05:58 +0000
commite39671c63b9e0fca78afcd5b6976d55eae00e6ca (patch)
tree9e677230fb7bce1bfb26a057e7f75f61e5b5aeda /dev-libs/cryptlib
parentVersion bump #363261 by Lars Wendler. (diff)
downloadgentoo-2-e39671c63b9e0fca78afcd5b6976d55eae00e6ca.tar.gz
gentoo-2-e39671c63b9e0fca78afcd5b6976d55eae00e6ca.tar.bz2
gentoo-2-e39671c63b9e0fca78afcd5b6976d55eae00e6ca.zip
Call Python-related functions only with USE="python".
(Portage version: 2.2.0_alpha29_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cryptlib')
-rw-r--r--dev-libs/cryptlib/cryptlib-3.4.0.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/dev-libs/cryptlib/cryptlib-3.4.0.ebuild b/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
index 03a4bac65e0d..0a8b818c35f0 100644
--- a/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.4.0.ebuild,v 1.4 2011/02/26 10:32:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.4.0.ebuild,v 1.5 2011/04/12 18:05:58 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -33,6 +33,12 @@ DEPEND="${RDEPEND}
DISTUTILS_SETUP_FILES=("bindings/setup.py")
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_unpack() {
# we need the -a option, so we can not use 'unpack'
unzip -qoa "${DISTDIR}/cl${MY_PV}.zip"
@@ -126,3 +132,15 @@ src_install() {
newdoc "${DOC_PREFIX}-manual.pdf" "manual.pdf" || die
fi
}
+
+pkg_postinst() {
+ if use python; then
+ distutils_pkg_postinst
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ distutils_pkg_postrm
+ fi
+}