summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-20 14:40:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-20 14:40:30 +0000
commitb75444bd73eb1bee891d39ccd40ebffaae55be54 (patch)
tree2a9c36681eda1299f7ccd356993b28dbe3a00ff6 /dev-libs/cryptlib/cryptlib-3.4.0.ebuild
parentStable on amd64 wrt bug #352117 (diff)
downloadgentoo-2-b75444bd73eb1bee891d39ccd40ebffaae55be54.tar.gz
gentoo-2-b75444bd73eb1bee891d39ccd40ebffaae55be54.tar.bz2
gentoo-2-b75444bd73eb1bee891d39ccd40ebffaae55be54.zip
Restrict Jython ABIs. DISTUTILS_SETUP_FILES should be an array.
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cryptlib/cryptlib-3.4.0.ebuild')
-rw-r--r--dev-libs/cryptlib/cryptlib-3.4.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/cryptlib/cryptlib-3.4.0.ebuild b/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
index cd4baa6ae779..57f91dcdb719 100644
--- a/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.4.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.4.0.ebuild,v 1.1 2011/01/20 14:17:34 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.4.0.ebuild,v 1.2 2011/01/20 14:40:30 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils eutils flag-o-matic multilib toolchain-funcs
@@ -30,8 +31,7 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
app-arch/unzip"
-DISTUTILS_SETUP_FILES="bindings/setup.py"
-RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SETUP_FILES=("bindings/setup.py")
src_unpack() {
# we need the -a option, so we can not use 'unpack'