summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-12 06:32:09 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-12 06:32:09 +0000
commit8dde84db012a35bad1250c358ffa6dfa39142c74 (patch)
treebc46e73d2a66100935133a14c75a1b3224c106bc /dev-libs/commoncpp2
parentPatch for bug #9536 (diff)
downloadgentoo-2-8dde84db012a35bad1250c358ffa6dfa39142c74.tar.gz
gentoo-2-8dde84db012a35bad1250c358ffa6dfa39142c74.tar.bz2
gentoo-2-8dde84db012a35bad1250c358ffa6dfa39142c74.zip
Removed RDEPEND=${DEPEND}
Diffstat (limited to 'dev-libs/commoncpp2')
-rw-r--r--dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild36
1 files changed, 13 insertions, 23 deletions
diff --git a/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild b/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
index c4311c2a1652..c5b282c340a3 100644
--- a/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
+++ b/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
@@ -1,25 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild,v 1.3 2002/10/05 05:39:10 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild,v 1.4 2002/11/12 06:30:27 vapier Exp $
-IUSE="doc xml2"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
-threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
-and system services"
+DESCRIPTION="C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/commonc++/"
-DEPEND="sys-libs/zlib
- xml2? ( dev-libs/libxml2 )
- doc? ( app-doc/doxygen )"
-
-RDEPEND=${DEPEND}
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="doc xml2"
+
+DEPEND="sys-libs/zlib
+ xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
src_compile() {
local myconf=""
@@ -28,24 +22,20 @@ src_compile() {
&& myconf="${myconf} --with-xml" \
|| myconf="${myconf} --without-xml"
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
- emake || die
+ emake || die "emake failed"
# kdoc disabled for now, it errors out
use doc && make doxy
}
-src_install () {
-
- einstall || die
+src_install() {
+ einstall
- dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ dodoc AUTHORS INSTALL NEWS ChangeLog README \
THANKS TODO COPYING COPYING.addendum
# the docs come out already compressed
- use doc && ( \
- dodoc commoncpp2-html-manual-1.0.1.tar.gz \
- commoncpp2-latex-manual-1.0.1.tar.gz
- )
+ use doc && dodoc commoncpp2-{html,latex}-manual-1.0.1.tar.gz
}