summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-04-14 07:27:59 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-04-14 07:27:59 +0000
commit75c88b43edd4549d93c957682e355855dca512a8 (patch)
tree9897b1e138f6193d98b22d071bfb0e393205ae5b /dev-libs/cloog
parentAnother try at having a proper init script. (diff)
downloadgentoo-2-75c88b43edd4549d93c957682e355855dca512a8.tar.gz
gentoo-2-75c88b43edd4549d93c957682e355855dca512a8.tar.bz2
gentoo-2-75c88b43edd4549d93c957682e355855dca512a8.zip
Version bump.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cloog')
-rw-r--r--dev-libs/cloog/ChangeLog7
-rw-r--r--dev-libs/cloog/cloog-0.16.2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-libs/cloog/ChangeLog b/dev-libs/cloog/ChangeLog
index 2cad897ca175..cb356c13c689 100644
--- a/dev-libs/cloog/ChangeLog
+++ b/dev-libs/cloog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/cloog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/ChangeLog,v 1.1 2011/01/08 06:05:23 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/ChangeLog,v 1.2 2011/04/14 07:27:59 dirtyepic Exp $
+
+*cloog-0.16.2 (14 Apr 2011)
+
+ 14 Apr 2011; Ryan Hill <dirtyepic@gentoo.org> +cloog-0.16.2.ebuild:
+ Version bump.
*cloog-0.16.1 (08 Jan 2011)
diff --git a/dev-libs/cloog/cloog-0.16.2.ebuild b/dev-libs/cloog/cloog-0.16.2.ebuild
new file mode 100644
index 000000000000..4e497e5ab7b2
--- /dev/null
+++ b/dev-libs/cloog/cloog-0.16.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/cloog-0.16.2.ebuild,v 1.1 2011/04/14 07:27:59 dirtyepic Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="A loop generator for scanning polyhedra"
+HOMEPAGE="http://www.bastoul.net/cloog/index.php"
+SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/gmp
+ >=dev-libs/isl-0.05.1
+ !<dev-libs/cloog-ppl-0.15.10"
+RDEPEND="${DEPEND}"
+
+DOCS=( README doc/cloog.pdf )
+
+src_configure() {
+ myeconfargs=(
+ --with-isl=system
+ --with-polylib=no
+ )
+ autotools-utils_src_configure
+}