summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-02 18:44:41 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-02 18:44:41 +0000
commita16863516914eac968543b6f35d21b38d187fd36 (patch)
tree212d625f8be82d791c02cf325efccb97dbc61bee /dev-libs/cdk
parentVersion bump to Jan 30 version (which was delayed because of a cron job failu... (diff)
downloadgentoo-2-a16863516914eac968543b6f35d21b38d187fd36.tar.gz
gentoo-2-a16863516914eac968543b6f35d21b38d187fd36.tar.bz2
gentoo-2-a16863516914eac968543b6f35d21b38d187fd36.zip
Version Bump
Fix for bug #186273 and #221611 (Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cdk')
-rw-r--r--dev-libs/cdk/ChangeLog10
-rw-r--r--dev-libs/cdk/cdk-5.0.20081105.ebuild50
-rw-r--r--dev-libs/cdk/files/cdk-5.0.20081105-ldflags.patch33
3 files changed, 91 insertions, 2 deletions
diff --git a/dev-libs/cdk/ChangeLog b/dev-libs/cdk/ChangeLog
index 6bc7533a9ac0..429a8c11f9f7 100644
--- a/dev-libs/cdk/ChangeLog
+++ b/dev-libs/cdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cdk
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.52 2008/11/27 15:50:23 jer Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.53 2009/02/02 18:44:41 drizzt Exp $
+
+*cdk-5.0.20081105 (02 Feb 2009)
+
+ 02 Feb 2009; <drizzt@gentoo.org> +files/cdk-5.0.20081105-ldflags.patch,
+ +cdk-5.0.20081105.ebuild:
+ Version Bump Fix for bug #186273 and #221611
27 Nov 2008; Jeroen Roovers <jer@gentoo.org> cdk-5.0.20060507.ebuild:
Stable for HPPA (bug #249039).
diff --git a/dev-libs/cdk/cdk-5.0.20081105.ebuild b/dev-libs/cdk/cdk-5.0.20081105.ebuild
new file mode 100644
index 000000000000..652b8482d926
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20081105.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/cdk-5.0.20081105.ebuild,v 1.1 2009/02/02 18:44:41 drizzt Exp $
+
+inherit eutils versionator toolchain-funcs
+
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf \
+ --with-ncurses --with-libtool \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ DOCUMENT_DIR="${D}/usr/share/doc/${MY_P}" install \
+ || die
+
+ if $(use examples); then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+}
diff --git a/dev-libs/cdk/files/cdk-5.0.20081105-ldflags.patch b/dev-libs/cdk/files/cdk-5.0.20081105-ldflags.patch
new file mode 100644
index 000000000000..b4cf4ddc9758
--- /dev/null
+++ b/dev-libs/cdk/files/cdk-5.0.20081105-ldflags.patch
@@ -0,0 +1,33 @@
+--- Makefile.in.orig 2008-10-31 00:40:47.000000000 +0100
++++ Makefile.in 2009-02-02 19:14:59.892008198 +0100
+@@ -267,7 +267,7 @@
+ all cdklib :: $(DEFAULT)
+
+ $(CDKLIB) :: $(OBJECTS)
+- @echo creating $@; $(LIBTOOL_CREATE) $@ $(LIB_OBJECT)
++ @echo creating $@; $(LIBTOOL_CREATE) $@ $(LIB_OBJECT) $(LIBS)
+ @$(RANLIB) $@
+
+ cdkshlib $(CDKSHLIB) :: $(CDKSHOBJS)
+--- aclocal.m4.orig 2009-02-02 19:13:54.256006211 +0100
++++ aclocal.m4 2009-02-02 19:14:39.332007971 +0100
+@@ -2344,7 +2344,7 @@
+ AC_MSG_ERROR(Cannot find libtool)
+ fi
+ ])dnl
+- LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LIBTOOL_OPTS} -o'
++ LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LDFLAGS} ${LIBTOOL_OPTS} -o'
+ LIB_OBJECT='${OBJECTS:.o=.lo}'
+ LIB_SUFFIX=.la
+ LIB_CLEAN='${LIBTOOL} --mode=clean'
+--- configure.orig 2009-02-02 19:30:01.000000000 +0100
++++ configure 2009-02-02 19:30:50.000000000 +0100
+@@ -2904,7 +2904,7 @@
+ if test -z "$LIBTOOL" ; then
+ { echo "configure: error: Cannot find libtool" 1>&2; exit 1; }
+ fi
+- LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LIBTOOL_OPTS} -o'
++ LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LDFLAGS} ${LIBTOOL_OPTS} -o'
+ LIB_OBJECT='${OBJECTS:.o=.lo}'
+ LIB_SUFFIX=.la
+ LIB_CLEAN='${LIBTOOL} --mode=clean'