summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-04 06:58:55 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-04 06:58:55 +0000
commitd681ab4a6e415491288d83491a9f824ce8c529f3 (patch)
treee50f7e5ad97318b5eae79c3fd7ac01e55550c914 /dev-libs/botan
parentdumb ebuild error correction (diff)
downloadgentoo-2-d681ab4a6e415491288d83491a9f824ce8c529f3.tar.gz
gentoo-2-d681ab4a6e415491288d83491a9f824ce8c529f3.tar.bz2
gentoo-2-d681ab4a6e415491288d83491a9f824ce8c529f3.zip
more improvements and refactoring
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/botan-1.8.0.ebuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/dev-libs/botan/botan-1.8.0.ebuild b/dev-libs/botan/botan-1.8.0.ebuild
index 0a6cb0e0361d..73d5fddf39f4 100644
--- a/dev-libs/botan/botan-1.8.0.ebuild
+++ b/dev-libs/botan/botan-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.0.ebuild,v 1.4 2009/01/04 06:10:20 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.0.ebuild,v 1.5 2009/01/04 06:58:55 dragonheart Exp $
inherit eutils multilib toolchain-funcs
@@ -30,12 +30,15 @@ DEPEND="${RDEPEND}
src_compile() {
# Modules that should work under any semi-recent Unix
local modules="alloc_mmap,egd,fd_unix,posix_rt"
+ local disable_modules="proc_walk,unix_procs,cpu_counter"
- if useq bzip2; then modules="$modules,bzip2"; fi
- if useq zlib; then modules="$modules,zlib"; fi
- if useq gmp; then modules="$modules,gnump"; fi
- if useq ssl; then modules="$modules,openssl"; fi
- if useq threads; then modules="$modules,pthread"; fi
+ if useq bzip2; then modules="${modules},bzip2"; fi
+ if useq zlib; then modules="${modules},zlib"; fi
+ if useq gmp; then modules="${modules},gnump"; fi
+ if useq ssl; then modules="${modules},openssl"; fi
+ if useq threads; then modules="${modules},pthreads"; else
+ disable_modules="${disable_modules},pthreads"
+ fi
# This is also supported on i586+ - hope this is correct.
# documention says sparc though not enables because of
@@ -43,13 +46,17 @@ src_compile() {
# If we have assembly code for this machine, use it
if [ "${ARCH}" = "x86" ]; then
- modules="$modules,mp_ia32,alg_ia32"
+ modules="${modules},mp_ia32,alg_ia32"
+ #below is untested.
+ #modules="${modules},mp_ia32,alg_ia32,mulop_ia32,serpent_ia32,ia32_eng,md4_ia32,md5_ia32,sha1_ia32,asm_ia32"
elif [ "${ARCH}" = "amd64" ]; then
- modules="$modules,mp_amd64"
- #modules="$modules,monty_amd64,mp_amd64,mulop_amd64"
+ modules="${modules},mp_amd64"
+ # monty_amd64 and mulop_amd64 had compile failures 20090103 Botan-1.8
+ #disable_modules="${disable_modules},monty_generic,mulop_generic"
+ #modules="${modules},monty_amd64,mp_amd64,mulop_amd64"
elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
"${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
- modules="$modules,mp_asm64"
+ modules="${modules},mp_asm64"
fi
# Enable v9 instructions for sparc64
@@ -61,6 +68,7 @@ src_compile() {
cd "${S}"
elog "Enabling modules: " ${modules}
+ elog "Disabling modules: " ${disable_modules}
# FIXME: We might actually be on *BSD or OS X...
./configure.pl \
@@ -72,8 +80,8 @@ src_compile() {
--cpu=${CHOSTARCH} \
--with-endian="$(tc-endian)" \
--with-tr1=system \
- --enable-modules=$modules \
- --disable-modules=proc_walk,unix_procs,cpu_counter \
+ --enable-modules=${modules} \
+ --disable-modules=${disable_modules} \
|| die "configure.pl failed"
emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" \
"LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"