summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-10-24 19:33:26 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-10-24 19:33:26 +0000
commit52a34ed197ce4339d52761ac9173488787758705 (patch)
tree2c906d67777658dbc23f145739e70126c6d72ab3 /dev-libs/botan
parentDropped ppc-macos keyword, see you in prefix. (diff)
downloadgentoo-2-52a34ed197ce4339d52761ac9173488787758705.tar.gz
gentoo-2-52a34ed197ce4339d52761ac9173488787758705.tar.bz2
gentoo-2-52a34ed197ce4339d52761ac9173488787758705.zip
Version bump, thanks to Jack Lloyd, added executable stack fix, closes bug#149213
(Portage version: 2.1.1)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog9
-rw-r--r--dev-libs/botan/botan-1.5.11.ebuild88
-rw-r--r--dev-libs/botan/files/botan-1.5.11-asm.patch14
-rw-r--r--dev-libs/botan/files/digest-botan-1.5.113
4 files changed, 113 insertions, 1 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 8ee7014d6a86..8c2a1ca6bb09 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.17 2006/02/20 22:11:11 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.18 2006/10/24 19:33:26 alonbl Exp $
+
+*botan-1.5.11 (24 Oct 2006)
+
+ 24 Oct 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/botan-1.5.11-asm.patch, +botan-1.5.11.ebuild:
+ Version bump, thanks to Jack Lloyd, added executable stack fix, closes
+ bug#149213
20 Feb 2006; Mark Loeser <halcy0n@gentoo.org> botan-1.5.5.ebuild:
Clean up leading whitespaces, add additional quoting, and drop the
diff --git a/dev-libs/botan/botan-1.5.11.ebuild b/dev-libs/botan/botan-1.5.11.ebuild
new file mode 100644
index 000000000000..483741a5274c
--- /dev/null
+++ b/dev-libs/botan/botan-1.5.11.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.5.11.ebuild,v 1.1 2006/10/24 19:33:26 alonbl Exp $
+
+inherit eutils
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/${MY_P}.tgz"
+
+KEYWORDS="~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.3 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.1 )
+ ssl? ( >=dev-libs/openssl-0.9.8c )"
+
+# configure.pl requires Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-asm.patch"
+}
+
+src_compile() {
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
+
+ if useq bzip2; then modules="$modules,comp_bzip2"; fi
+ if useq zlib; then modules="$modules,comp_zlib"; fi
+ if useq gmp; then modules="$modules,eng_gmp"; fi
+ if useq ssl; then modules="$modules,eng_ossl"; fi
+
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+
+ if [ "${ARCH}" = "alpha" -o "${ARCH}" = "amd64" ] || \
+ [ "${ARCH}" = "x86" -a "${CHOST:0:4}" != "i386" -a "${CHOST:0:4}" != "i486" ]; then
+ modules="$modules,tm_hard"
+ fi
+
+ # If we have assembly code for this machine, use it
+ if [ "${ARCH}" = "x86" ]; then
+ modules="$modules,mp_ia32,alg_ia32"
+ elif [ "${ARCH}" = "amd64" ]; then
+ modules="$modules,mp_amd64"
+ elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
+ "${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
+ modules="$modules,mp_asm64"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="$(echo ${CHOST} | cut -d - -f 1)"
+ fi
+
+ cd "${S}"
+ einfo "Enabling modules: " ${modules}
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl --noauto gcc-linux-${CHOSTARCH} --modules=$modules ||
+ die "configure.pl failed"
+ emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake check || die "emake check failed"
+ env LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make INSTALLROOT="${D}/usr" install || die "make install failed"
+}
diff --git a/dev-libs/botan/files/botan-1.5.11-asm.patch b/dev-libs/botan/files/botan-1.5.11-asm.patch
new file mode 100644
index 000000000000..0a48eb0f3368
--- /dev/null
+++ b/dev-libs/botan/files/botan-1.5.11-asm.patch
@@ -0,0 +1,14 @@
+diff -urNp Botan-1.5.11.org/modules/alg_ia32/asm_macr.h Botan-1.5.11/modules/alg_ia32/asm_macr.h
+--- Botan-1.5.11.org/modules/alg_ia32/asm_macr.h 2006-09-10 08:59:20.000000000 +0300
++++ Botan-1.5.11/modules/alg_ia32/asm_macr.h 2006-10-24 21:14:15.000000000 +0200
+@@ -6,6 +6,10 @@
+ #ifndef BOTAN_EXT_ASM_MACROS_H__
+ #define BOTAN_EXT_ASM_MACROS_H__
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
++
+ /*************************************************
+ * General/Global Macros *
+ *************************************************/
diff --git a/dev-libs/botan/files/digest-botan-1.5.11 b/dev-libs/botan/files/digest-botan-1.5.11
new file mode 100644
index 000000000000..41a922e3ffb9
--- /dev/null
+++ b/dev-libs/botan/files/digest-botan-1.5.11
@@ -0,0 +1,3 @@
+MD5 6fc71b20d30dedd93b0c19a74b2ae0c2 Botan-1.5.11.tgz 1373484
+RMD160 6a080d69eb53d8a7c0c3c70848401e397e0ce8b3 Botan-1.5.11.tgz 1373484
+SHA256 efff1ad12e22bdbf69f007a58b49a273a548c4bf0b83cac0a92f6d332c8f43e5 Botan-1.5.11.tgz 1373484