summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-15 01:03:30 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-15 01:03:30 +0000
commit38778296a993e85cd2da12e9250158f2d51fc27e (patch)
tree193c2438fa95ea8a1280be79c8439c2b6bfa113b /dev-libs/botan
parentFix typo (diff)
downloadgentoo-2-38778296a993e85cd2da12e9250158f2d51fc27e.tar.gz
gentoo-2-38778296a993e85cd2da12e9250158f2d51fc27e.tar.bz2
gentoo-2-38778296a993e85cd2da12e9250158f2d51fc27e.zip
Version bump per bug#434050
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog10
-rw-r--r--dev-libs/botan/botan-1.10.3.ebuild95
2 files changed, 102 insertions, 3 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 5594842536c5..c7c1c9af5a71 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/botan
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.71 2011/08/20 14:11:55 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.72 2012/12/15 01:03:30 alonbl Exp $
+
+*botan-1.10.3 (15 Dec 2012)
+
+ 15 Dec 2012; <alonbl@gentoo.org> +botan-1.10.3.ebuild:
+ Version bump per bug#434050
*botan-1.10.1 (20 Aug 2011)
@@ -315,4 +320,3 @@
+botan-1.4.3.ebuild:
initial import as per bug #51938. Thanks to the author (Jack Lloyd
<lloyd@randombit.net>) for the program and ebuild
-
diff --git a/dev-libs/botan/botan-1.10.3.ebuild b/dev-libs/botan/botan-1.10.3.ebuild
new file mode 100644
index 000000000000..153429ecfed2
--- /dev/null
+++ b/dev-libs/botan/botan-1.10.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.10.3.ebuild,v 1.1 2012/12/15 01:03:30 alonbl Exp $
+
+EAPI="3"
+#PYTHON_BDEPEND="2"
+
+inherit eutils multilib python toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://files.randombit.net/botan/${MY_P}.tbz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~ppc-macos"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl threads zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ ssl? ( >=dev-libs/openssl-0.9.8g )"
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Install documentation in /usr/share/doc/${PF}.
+ sed -e "/^DOCDIR *=/s/Botan-\$(VERSION)/${PF}/" -i src/build-data/makefile/unix_shr.in || die "sed failed"
+}
+
+src_configure() {
+ local disable_modules="proc_walk,unix_procs,cpu_counter"
+
+ if ! use threads; then
+ disable_modules="${disable_modules},pthreads"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ cd "${S}"
+ elog "Disabling modules: ${disable_modules}"
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ # foobared buildsystem, --prefix translates into DESTDIR, see also make
+ # install in src_install, we need the correct live-system prefix here on
+ # Darwin for a shared lib with correct install_name
+ ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system \
+ $(use_with bzip2) \
+ $(use_with gmp gnump) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ --disable-modules=${disable_modules} \
+ || die "configure.py failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
+ LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}usr" install || die "emake install failed"
+}