summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-11 05:50:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-11 05:50:39 +0000
commitbb8bda9b04344bd2a17363b8597454922cd2f398 (patch)
treecda7b4ec3ff909dac574222b5f160d92c02f4835 /dev-libs/boost
parentAdd patches from Andrej Filipcic to fix building with linux-3.6 #437278 by Ol... (diff)
downloadgentoo-2-bb8bda9b04344bd2a17363b8597454922cd2f398.tar.gz
gentoo-2-bb8bda9b04344bd2a17363b8597454922cd2f398.tar.bz2
gentoo-2-bb8bda9b04344bd2a17363b8597454922cd2f398.zip
Import the pkg_preinst bit to make sure the links are really gone.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.52.0-r2.ebuild12
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index ff9df1907575..5d9784868d78 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.278 2012/11/11 05:27:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.279 2012/11/11 05:50:39 flameeyes Exp $
+
+ 11 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> boost-1.52.0-r2.ebuild:
+ Import the pkg_preinst bit to make sure the links are really gone.
*boost-1.52.0-r2 (11 Nov 2012)
diff --git a/dev-libs/boost/boost-1.52.0-r2.ebuild b/dev-libs/boost/boost-1.52.0-r2.ebuild
index b3871594e1ea..796f379c8b2f 100644
--- a/dev-libs/boost/boost-1.52.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.52.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.52.0-r2.ebuild,v 1.1 2012/11/11 05:27:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.52.0-r2.ebuild,v 1.2 2012/11/11 05:50:39 flameeyes Exp $
EAPI="5"
PYTHON_DEPEND="python? *"
@@ -300,6 +300,16 @@ EOF
fi
}
+pkg_preinst() {
+ # Yai for having symlinks that are nigh-impossible to remove without
+ # resorting to dirty hacks like these. Removes lingering symlinks
+ # from the slotted versions.
+ local symlink
+ for symlink in "${EROOT}usr/include/boost" "${EROOT}usr/share/boostbook"; do
+ [[ -L ${symlink} ]] && rm -f "${symlink}"
+ done
+}
+
pkg_postinst() {
if use mpi && use python; then
python_mod_optimize boost