summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-03-23 23:13:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-03-23 23:13:39 +0000
commitad8a8995020611fd582489b95e549c6447a5ebe2 (patch)
tree99bad8ba5b560c470ecbf1268cf95016736b2e9a /dev-libs/boost
parentVersion bump. Using cmake-utils now. Updated ebuild thanks to Daniel Pielmeier. (diff)
downloadgentoo-2-ad8a8995020611fd582489b95e549c6447a5ebe2.tar.gz
gentoo-2-ad8a8995020611fd582489b95e549c6447a5ebe2.tar.bz2
gentoo-2-ad8a8995020611fd582489b95e549c6447a5ebe2.zip
Fix testsuite postprocessing for bug #245192.
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.35.0-r2.ebuild24
2 files changed, 18 insertions, 11 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index d36ba881783a..1fb590d43633 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.144 2009/02/07 19:58:38 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.145 2009/03/23 23:13:39 dirtyepic Exp $
+
+ 23 Mar 2009; Ryan Hill <dirtyepic@gentoo.org> boost-1.35.0-r2.ebuild:
+ Fix testsuite postprocessing for bug #245192.
07 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
boost-1.35.0-r1.ebuild:
diff --git a/dev-libs/boost/boost-1.35.0-r2.ebuild b/dev-libs/boost/boost-1.35.0-r2.ebuild
index b3deab4f1a85..18383dc74486 100644
--- a/dev-libs/boost/boost-1.35.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.1 2008/09/01 18:37:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.2 2009/03/23 23:13:39 dirtyepic Exp $
inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -35,11 +35,11 @@ pkg_setup() {
if has test ${FEATURES} ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
-
- ewarn "The tests may take several hours on a recent machine"
- ewarn "but they will not fail (unless something weird happens ;-)"
- ewarn "This is because the tests depend on the used compiler/-version"
- ewarn "and the platform and upstream says that this is normal."
+ ewarn "The testsuite may take several hours to run on a modern system."
+ ewarn "It is normal to see some tests failing, as some are dependent"
+ ewarn "on compiler version and platform. Unless something weird"
+ ewarn "happens, the ebuild should continue installing as normal."
+ ewarn
ewarn "If you are interested in the results, please take a look at the"
ewarn "generated results page:"
ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
@@ -73,7 +73,7 @@ generate_options() {
# Using optimization=off would for example add
# "-O0" and override "-O2" set by the user.
# Please take a look at the boost-build ebuild
- # for more infomration.
+ # for more information.
OPTIONS="gentoorelease"
use debug && OPTIONS="gentoodebug"
@@ -157,6 +157,7 @@ src_compile() {
${OPTIONS} \
--prefix="${D}/usr" \
--layout=system \
+ process_jam_log compiler_status \
|| die "building regression test helpers failed"
fi
@@ -247,7 +248,10 @@ src_test() {
--dump-tests 2>&1 | tee regress.log
# Postprocessing
- cat regress.log | "${S}/dist/bin/process_jam_log" --v2
+ process_jam_log=$(find "${S}"/tools/regression/build/bin -name process_jam_log -print);
+ compiler_status=$(find "${S}"/tools/regression/build/bin -name compiler_status -print);
+
+ cat regress.log | "${process_jam_log}" --v2
if test $? != 0 ; then
die "Postprocessing the build log failed"
fi
@@ -257,7 +261,7 @@ src_test() {
__EOF__
# Generate the build log html summary page
- "${S}/dist/bin/compiler_status" --v2 \
+ "${compiler_status}" --v2 \
--comment "${S}/status/comment.html" "${S}" \
cs-$(uname).html cs-$(uname)-links.html
if test $? != 0 ; then