summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-03-20 07:14:55 +0000
committerDaniel Goller <morfic@gentoo.org>2005-03-20 07:14:55 +0000
commita63463a9ec94fabe4072c6390bff754ea6fe4493 (patch)
tree6355092dd2c9cf33643ceec55fde30289a2f119f /dev-libs/boost
parentReduced the RDEPENDencies to the PEAR packages that are listed in http://cvs.... (diff)
downloadgentoo-2-a63463a9ec94fabe4072c6390bff754ea6fe4493.tar.gz
gentoo-2-a63463a9ec94fabe4072c6390bff754ea6fe4493.tar.bz2
gentoo-2-a63463a9ec94fabe4072c6390bff754ea6fe4493.zip
fixed parallel building for distcc and SMP users
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/Manifest14
-rw-r--r--dev-libs/boost/boost-1.32.0-r1.ebuild66
3 files changed, 68 insertions, 17 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index fad367d100b3..4b88c0800d92 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.46 2005/03/18 06:56:46 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.47 2005/03/20 07:14:55 morfic Exp $
+
+ 20 Mar 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r1.ebuild:
+ fixed parallel building for distcc and SMP users
18 Mar 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r1.ebuild:
depend on icc 8 as 7 is no longer supported by intel
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 0ae7b65d3284..9bff5105b3e6 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,13 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 12f996aa5f489e4e51055e537ea059a8 boost-1.31.0.ebuild 3967
MD5 8d4eca3eb59bc23e2d53b3d0cfd06c97 boost-1.32.0.ebuild 2294
MD5 d259ae434e176df207cba3deab973f61 boost-1.29.0.ebuild 1426
+MD5 4ba97027d144edd2743cced86a3d01d1 boost-1.32.0-r2.ebuild 4210
MD5 34d13e0eeb58e13e1992908d04d51b45 boost-1.30.0.ebuild 2973
MD5 670c7efff8b9fd91618479875eba5519 ChangeLog 6935
MD5 ac17509c51769ef73346e3d3d7733f67 metadata.xml 347
-MD5 f84358ea9581a62ed2f593d83c68876a boost-1.32.0-r1.ebuild 3666
+MD5 4ba97027d144edd2743cced86a3d01d1 boost-1.32.0-r1.ebuild 4210
MD5 4759f9391ad73c487d4f6b3dbf8632a8 boost-1.30.2.ebuild 2960
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
MD5 2b36d47323b021671d391600501685cc files/digest-boost-1.30.0 66
@@ -15,10 +13,4 @@ MD5 a09c431deb3a25504525921685cd0e57 files/digest-boost-1.30.2 66
MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0 67
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r1 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCOnclUpKYMelfdYERAoYaAJ9dhp3V092UlkopVKYiSYRNXwT4BgCfYuZF
-pmozfro7SonPpDTVLwcymQo=
-=TOhn
------END PGP SIGNATURE-----
+MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r2 67
diff --git a/dev-libs/boost/boost-1.32.0-r1.ebuild b/dev-libs/boost/boost-1.32.0-r1.ebuild
index bb5a5e35c44a..590758233998 100644
--- a/dev-libs/boost/boost-1.32.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.32.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.9 2005/03/18 06:56:46 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.10 2005/03/20 07:14:55 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
-inherit python multilib
+inherit python multilib eutils
BOOST_PV1=${PV/./_}
BOOST_PV=${BOOST_PV1/./_}
@@ -37,6 +37,19 @@ pkg_setup() {
fi
BOOSTJAM=./tools/build/jam_src/bin.linux${arch}/bjam
+
+ einfo "MAKEOPTS are: ${MAKEOPTS}"
+
+ # we dont like what get_number_of_jobs does, so we borrow what counts to us,
+ # thanks H?kan Wessberg <nacka-gentoo@refug.org>, bug #13565
+
+ if [ "`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | wc -l`" -gt 0 ]; then
+ ADMINOPTS="`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | cut -d= -f2 | sed 's/\"//g'`"
+ ADMINPARAM="`echo ${ADMINOPTS} | gawk '{match($0, /-j *[0-9]*/, opt); print opt[0]}'`"
+ NUMJOBS="${ADMINPARAM}"
+ fi
+
+ einfo "number of jobs is: ${NUMJOBS}"
}
src_compile() {
@@ -46,6 +59,49 @@ src_compile() {
cd ${S}/tools/build/jam_src
./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
cd ${S}
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ else
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ fi
+
}
@@ -60,7 +116,7 @@ src_install () {
if use icc ; then
export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
export GXX_INCLUDE="/usr/include"
- ${BOOSTJAM} -sBOOST_ROOT=${S} \
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYVER} \
-sTOOLS=${BOOST_TOOLSET} \
@@ -69,7 +125,7 @@ src_install () {
--layout=system \
install || die "Install failed"
else
- ${BOOSTJAM} -sBOOST_ROOT=${S} \
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYVER} \
-sTOOLS=${BOOST_TOOLSET} \
@@ -79,7 +135,7 @@ src_install () {
fi
# Install documentation; seems to be mostly under ${S}/lib
- # install documentation
+ # install documentation
dodoc README
dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
dohtml -A pdf -r more