summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-07-15 16:27:59 +0000
committerMatt Turner <mattst88@gentoo.org>2011-07-15 16:27:59 +0000
commit850e67c713fe0894228a3cf330521fccd1d64ac9 (patch)
tree9722c781578ad33d1900b59f314b9ec3674e52fa /dev-libs/boost
parentppc64 stable wrt #363937 (diff)
downloadgentoo-2-850e67c713fe0894228a3cf330521fccd1d64ac9.tar.gz
gentoo-2-850e67c713fe0894228a3cf330521fccd1d64ac9.tar.bz2
gentoo-2-850e67c713fe0894228a3cf330521fccd1d64ac9.zip
Disable long-double support on MIPS only for o32 ABI (no longer disable long-double on n32 and n64 ABIs)
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog8
-rw-r--r--dev-libs/boost/boost-1.41.0-r3.ebuild4
-rw-r--r--dev-libs/boost/boost-1.42.0-r1.ebuild4
-rw-r--r--dev-libs/boost/boost-1.42.0-r2.ebuild4
-rw-r--r--dev-libs/boost/boost-1.42.0.ebuild4
-rw-r--r--dev-libs/boost/boost-1.45.0.ebuild4
-rw-r--r--dev-libs/boost/boost-1.46.1.ebuild4
7 files changed, 19 insertions, 13 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index b5536a26961e..ac960db6ee82 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.220 2011/05/15 11:03:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.221 2011/07/15 16:27:59 mattst88 Exp $
+
+ 15 Jul 2011; Matt Turner <mattst88@gentoo.org> boost-1.41.0-r3.ebuild,
+ boost-1.42.0.ebuild, boost-1.42.0-r1.ebuild, boost-1.42.0-r2.ebuild,
+ boost-1.45.0.ebuild, boost-1.46.1.ebuild:
+ Disable long-double support on MIPS only for o32 ABI (no longer disable
+ long-double on n32 and n64 ABIs)
15 May 2011; Markos Chandras <hwoarang@gentoo.org> boost-1.46.1.ebuild,
+files/boost-1.46.1-python32.patch:
diff --git a/dev-libs/boost/boost-1.41.0-r3.ebuild b/dev-libs/boost/boost-1.41.0-r3.ebuild
index c5e60f9b45f7..9935dc930aff 100644
--- a/dev-libs/boost/boost-1.41.0-r3.ebuild
+++ b/dev-libs/boost/boost-1.41.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0-r3.ebuild,v 1.13 2011/04/05 05:23:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0-r3.ebuild,v 1.14 2011/07/15 16:27:59 mattst88 Exp $
EAPI="2"
@@ -173,7 +173,7 @@ __EOF__
use python || OPTIONS="${OPTIONS} --without-python"
# https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
- if use sparc || use mips || use hppa || use arm || use x86-fbsd || use sh; then
+ if use sparc || { use mips && [[ ${ABI} = "o32" ]]; } || use hppa || use arm || use x86-fbsd || use sh; then
OPTIONS="${OPTIONS} --disable-long-double"
fi
diff --git a/dev-libs/boost/boost-1.42.0-r1.ebuild b/dev-libs/boost/boost-1.42.0-r1.ebuild
index 12bda20c555a..558448362894 100644
--- a/dev-libs/boost/boost-1.42.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.42.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0-r1.ebuild,v 1.3 2011/04/05 05:23:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0-r1.ebuild,v 1.4 2011/07/15 16:27:59 mattst88 Exp $
EAPI="2"
@@ -158,7 +158,7 @@ __EOF__
use python || OPTIONS="${OPTIONS} --without-python"
# https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
- if use sparc || use mips || use hppa || use arm || use x86-fbsd || use sh; then
+ if use sparc || { use mips && [[ ${ABI} = "o32" ]]; } || use hppa || use arm || use x86-fbsd || use sh; then
OPTIONS="${OPTIONS} --disable-long-double"
fi
diff --git a/dev-libs/boost/boost-1.42.0-r2.ebuild b/dev-libs/boost/boost-1.42.0-r2.ebuild
index 2cddbd8cd0d3..0603f5a2d399 100644
--- a/dev-libs/boost/boost-1.42.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.42.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0-r2.ebuild,v 1.11 2011/04/16 11:30:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0-r2.ebuild,v 1.12 2011/07/15 16:27:59 mattst88 Exp $
EAPI="2"
@@ -159,7 +159,7 @@ __EOF__
use python || OPTIONS="${OPTIONS} --without-python"
# https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
- if use sparc || use mips || use hppa || use arm || use x86-fbsd || use sh; then
+ if use sparc || { use mips && [[ ${ABI} = "o32" ]]; } || use hppa || use arm || use x86-fbsd || use sh; then
OPTIONS="${OPTIONS} --disable-long-double"
fi
diff --git a/dev-libs/boost/boost-1.42.0.ebuild b/dev-libs/boost/boost-1.42.0.ebuild
index a85d3a949fe9..aa9035aabb51 100644
--- a/dev-libs/boost/boost-1.42.0.ebuild
+++ b/dev-libs/boost/boost-1.42.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0.ebuild,v 1.5 2011/04/05 05:23:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.42.0.ebuild,v 1.6 2011/07/15 16:27:59 mattst88 Exp $
EAPI="2"
@@ -157,7 +157,7 @@ __EOF__
use python || OPTIONS="${OPTIONS} --without-python"
# https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
- if use sparc || use mips || use hppa || use arm || use x86-fbsd || use sh; then
+ if use sparc || { use mips && [[ ${ABI} = "o32" ]]; } || use hppa || use arm || use x86-fbsd || use sh; then
OPTIONS="${OPTIONS} --disable-long-double"
fi
diff --git a/dev-libs/boost/boost-1.45.0.ebuild b/dev-libs/boost/boost-1.45.0.ebuild
index f46b636544af..ea01e5fe5e27 100644
--- a/dev-libs/boost/boost-1.45.0.ebuild
+++ b/dev-libs/boost/boost-1.45.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.45.0.ebuild,v 1.6 2011/04/05 05:23:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.45.0.ebuild,v 1.7 2011/07/15 16:27:59 mattst88 Exp $
EAPI="2"
@@ -153,7 +153,7 @@ __EOF__
use python || OPTIONS="${OPTIONS} --without-python"
# https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
- if use sparc || use mips || use hppa || use arm || use x86-fbsd || use sh; then
+ if use sparc || { use mips && [[ ${ABI} = "o32" ]]; } || use hppa || use arm || use x86-fbsd || use sh; then
OPTIONS="${OPTIONS} --disable-long-double"
fi
diff --git a/dev-libs/boost/boost-1.46.1.ebuild b/dev-libs/boost/boost-1.46.1.ebuild
index 909e2a935019..47bade6b0a6c 100644
--- a/dev-libs/boost/boost-1.46.1.ebuild
+++ b/dev-libs/boost/boost-1.46.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.46.1.ebuild,v 1.5 2011/05/15 19:59:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.46.1.ebuild,v 1.6 2011/07/15 16:27:59 mattst88 Exp $
EAPI="2"
@@ -160,7 +160,7 @@ __EOF__
use python || OPTIONS="${OPTIONS} --without-python"
# https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
- if use sparc || use mips || use hppa || use arm || use x86-fbsd || use sh; then
+ if use sparc || { use mips && [[ ${ABI} = "o32" ]]; } || use hppa || use arm || use x86-fbsd || use sh; then
OPTIONS="${OPTIONS} --disable-long-double"
fi