summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-03-05 05:33:08 +0000
committerDaniel Goller <morfic@gentoo.org>2005-03-05 05:33:08 +0000
commit18242961e9e7ea63559e0095f772a668c58dc8c4 (patch)
tree70a5ac74e5c9f887cbb8fbe3d14c2eb89fc25d6a /dev-libs/boost
parentVersion bumped. Bug 83576. Added dar32 and dar64 USE flags. (diff)
downloadgentoo-2-18242961e9e7ea63559e0095f772a668c58dc8c4.tar.gz
gentoo-2-18242961e9e7ea63559e0095f772a668c58dc8c4.tar.bz2
gentoo-2-18242961e9e7ea63559e0095f772a668c58dc8c4.zip
Cleaned up and with symlinks we should be able to put bug #78373 to rest, i should commit this 30 minutes from now, then it could count towards bugday, hey i know let's count it anyway it is tomorrow somewhere
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog11
-rw-r--r--dev-libs/boost/Manifest12
-rw-r--r--dev-libs/boost/boost-1.32.0-r1.ebuild105
-rw-r--r--dev-libs/boost/files/digest-boost-1.32.0-r11
4 files changed, 118 insertions, 11 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 862b6b189c9a..a37fc7dbb97b 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.37 2005/03/03 11:31:44 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.38 2005/03/05 05:33:08 morfic Exp $
+
+*boost-1.32.0-r1 (04 Mar 2005)
+
+ 04 Mar 2005; Daniel Goller <morfic@gentoo.org> +boost-1.32.0-r1.ebuild:
+ Compiled with --layout=system for the short libnames, linked the long ones
+ Everyone and everything should now be happy Serialization linking issues are
+ with binutils, as long as we only have the .a we will need 2.15.90.0.* for
+ this lib Time permitting we might have to port what is in cvs, as that
+ builds a shared lib for us which would link with any stable binutils
01 Mar 2005; Daniel Goller <morfic@gentoo.org> metadata.xml,
boost-1.32.0.ebuild:
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 7757454a70d8..e40309b81686 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,22 +1,14 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 12f996aa5f489e4e51055e537ea059a8 boost-1.31.0.ebuild 3967
MD5 8d4eca3eb59bc23e2d53b3d0cfd06c97 boost-1.32.0.ebuild 2294
MD5 d259ae434e176df207cba3deab973f61 boost-1.29.0.ebuild 1426
MD5 34d13e0eeb58e13e1992908d04d51b45 boost-1.30.0.ebuild 2973
MD5 15b9433fbdfd6ea6dbad409c60f87ed2 ChangeLog 5419
MD5 ac17509c51769ef73346e3d3d7733f67 metadata.xml 347
+MD5 457c0bacaa0cb88324ad780a5f2844d6 boost-1.32.0-r1.ebuild 2480
MD5 4759f9391ad73c487d4f6b3dbf8632a8 boost-1.30.2.ebuild 2960
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
MD5 2b36d47323b021671d391600501685cc files/digest-boost-1.30.0 66
MD5 a09c431deb3a25504525921685cd0e57 files/digest-boost-1.30.2 66
MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCJusuUpKYMelfdYERAuXEAJ9Orli0vrTVqvNCqiHTcb26sPUBPQCdF5/J
-k/Umalc0/ZdiRntL/RPwylM=
-=q1Ol
------END PGP SIGNATURE-----
+MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r1 67
diff --git a/dev-libs/boost/boost-1.32.0-r1.ebuild b/dev-libs/boost/boost-1.32.0-r1.ebuild
new file mode 100644
index 000000000000..6b47af470183
--- /dev/null
+++ b/dev-libs/boost/boost-1.32.0-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.1 2005/03/05 05:33:08 morfic Exp $
+
+# This ebuild was generated by Ebuilder v0.4.
+inherit python
+
+BOOST_PV1=${PV/./_}
+BOOST_PV=${BOOST_PV1/./_}
+S="${WORKDIR}/${PN}_${BOOST_PV}"
+DESCRIPTION="Boost Libraries for C++"
+SRC_URI="mirror://sourceforge/boost/${PN}_${BOOST_PV}.tar.bz2"
+HOMEPAGE="http://www.boost.org/"
+LICENSE="freedist Boost-1.0"
+SLOT="1"
+IUSE="icc"
+
+DEPEND="sys-devel/gcc
+ dev-lang/python"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
+
+pkg_setup() {
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if use icc ; then
+ BOOST_TOOLSET="intel-linux"
+ else
+ BOOST_TOOLSET="gcc"
+ fi
+
+ BOOSTJAM=./tools/build/jam_src/bin.linux${arch}/bjam
+}
+
+src_compile() {
+ echo ${LAYOUT}
+ python_version
+ # Build bjam, a jam variant, which is used instead of make
+ cd ${S}/tools/build/jam_src
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd ${S}
+
+}
+
+src_install () {
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ ${BOOSTJAM} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ --prefix=${D}/usr \
+ --layout=system \
+ install || die "Install failed"
+
+ # Install documentation; seems to be mostly under ${S}/lib
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
+ dohtml -A pdf -r more
+ dohtml -r people
+ dohtml -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${P}/html/\{\} \;
+
+ #and finally set "default" links to -gcc-mt versions
+ cd ${D}/usr/lib
+
+ for fn in `ls -1 *.so|cut -d- -f1|sort|uniq`; do
+ dosym $fn.so $fn-gcc.so
+ dosym $fn-mt.so $fn-gcc-mt.so
+ dosym $fn-d.so $fn-gcc-d.so
+ dosym $fn-mt-d.so $fn-gcc-d.so
+ done
+
+ for fn in `ls -1 *.a|cut -d- -f1|sort|uniq`; do
+ dosym $fn.a $fn-gcc.a
+ dosym $fn-mt.a $fn-gcc-mt.a
+ dosym $fn-d.a $fn-gcc-d.a
+ dosym $fn-mt-d.a $fn-gcc-d.a
+ done
+
+}
diff --git a/dev-libs/boost/files/digest-boost-1.32.0-r1 b/dev-libs/boost/files/digest-boost-1.32.0-r1
new file mode 100644
index 000000000000..f5cfec51b895
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.32.0-r1
@@ -0,0 +1 @@
+MD5 e1d1fc7b8fc8c51df4564c2188ca51cb boost_1_32_0.tar.bz2 10181552