summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-18 23:17:00 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-18 23:17:00 +0000
commit007335ffd72e8d9c49ad9e3716a8d95881af0f95 (patch)
treecf4e400d6d1189b80c5554ddeebf5c226cb67113 /dev-libs/boost
parentVersion bump. (diff)
downloadgentoo-2-007335ffd72e8d9c49ad9e3716a8d95881af0f95.tar.gz
gentoo-2-007335ffd72e8d9c49ad9e3716a8d95881af0f95.tar.bz2
gentoo-2-007335ffd72e8d9c49ad9e3716a8d95881af0f95.zip
New snapshot added: All boost-tools are now available via the tools USE-flag.
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog8
-rw-r--r--dev-libs/boost/boost-1.34_pre20061214.ebuild172
-rw-r--r--dev-libs/boost/files/digest-boost-1.34_pre200612143
-rw-r--r--dev-libs/boost/files/random-Jamfile15
4 files changed, 197 insertions, 1 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index b53fc3643b2b..0d43e08c311e 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.96 2006/11/27 16:06:54 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.97 2006/12/18 23:17:00 dev-zero Exp $
+
+*boost-1.34_pre20061214 (18 Dec 2006)
+
+ 18 Dec 2006; Tiziano Müller <dev-zero@gentoo.org> +files/random-Jamfile,
+ +boost-1.34_pre20061214.ebuild:
+ New snapshot added: All boost-tools are now available via the tools USE-flag.
27 Nov 2006; Tiziano Müller <dev-zero@gentoo.org> boost-1.33.1-r1.ebuild:
Added icu USE-flag and dependency, bug #141170
diff --git a/dev-libs/boost/boost-1.34_pre20061214.ebuild b/dev-libs/boost/boost-1.34_pre20061214.ebuild
new file mode 100644
index 000000000000..ed99b33a4984
--- /dev/null
+++ b/dev-libs/boost/boost-1.34_pre20061214.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20061214.ebuild,v 1.1 2006/12/18 23:17:00 dev-zero Exp $
+
+inherit distutils flag-o-matic multilib python toolchain-funcs versionator
+
+KEYWORDS="~amd64 ~x86"
+
+MY_P=${PN}_$(replace_all_version_separators _)
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+SRC_URI="http://dev.gentoo.org/~dev-zero/distfiles/${MY_P}.tar.bz2"
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+IUSE="debug doc icc icu pyste static threads threadsonly tools"
+
+DEPEND="icu? ( >=dev-libs/icu-3.2 )
+ sys-libs/zlib
+ ~dev-util/boost-build-${PV}"
+RDEPEND="${DEPEND}
+ pyste? ( dev-cpp/gccxml dev-python/elementtree )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm boost-build.jam
+
+ mkdir -p libs/random/build
+ cp "${FILESDIR}/random-Jamfile" libs/random/build/Jamfile.v2
+}
+
+generate_options() {
+ LINK_OPTIONS="shared"
+ use static && LINK_OPTIONS="${LINK_OPTIONS} static"
+
+ if ! use debug ; then
+ OPTIONS="release debug-symbols=none"
+ else
+ OPTIONS="debug"
+ fi
+
+ OPTIONS="${OPTIONS} optimization=none"
+
+ if use threads ; then
+ if use threadsonly ; then
+ OPTIONS="${OPTIONS} threading=multi"
+ else
+ OPTIONS="${OPTIONS} threading=single,multi"
+ fi
+ else
+ OPTIONS="${OPTIONS} threading=single"
+ fi
+
+ use icu && OPTIONS="${OPTIONS} -sHAVE_ICU=1 -sICU_PATH=\"${ROOT}/usr\""
+
+}
+
+generate_userconfig() {
+ einfo "Writing new user-config.jam"
+ python_version
+
+ local compiler compilerVersion compilerExecutable
+ if use icc ; then
+ compiler=intel-linux
+ compilerExecutable=icc
+ elif [ "${ARCH}" == "ppc-macos" ] ; then
+ compiler=darwin
+ compilerExecutable=cc
+ else
+ compiler=gcc
+ compilerVersion=$(gcc-version)
+ compilerExecutable=$(tc-getCXX)
+ fi
+
+ cat > "${HOME}/user-config.jam" << __EOF__
+import toolset : using ;
+import toolset : flags ;
+using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
+using python : ${PYVER} : ${ROOT}usr : ${ROOT}usr/include/python${PYVER} : ${ROOT}usr/lib/python${PYVER} ;
+__EOF__
+
+}
+
+src_compile() {
+
+ NUMJOBS=$(sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/' <<< ${MAKEOPTS})
+
+ generate_userconfig
+ generate_options
+
+ BOOST_ROOT=${S}
+ BOOST_BUILD_PATH=${ROOT}/usr/share/boost-build
+
+ # Note: The line "debug-symbols=on" only adds '-g' to compiler and linker invocation
+ # and prevents boost-build from stripping the libraries/binaries
+ for linkoption in ${LINK_OPTIONS} ; do
+ einfo "Building ${linkoption} libraries"
+ bjam ${NUMJOBS} \
+ ${OPTIONS} \
+ runtime-link=${linkoption} link=${linkoption} \
+ --prefix="${D}/usr" \
+ --layout=system \
+ || die "building boost failed"
+ done
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_compile
+ fi
+
+ if use tools; then
+ cd "${S}/tools/"
+ # We have to set optimization to -O0 or -O1 to work aroudn a gcc-bug
+ # optimization=off adds -O0 to the compiler call and overwrites our settings.
+ bjam ${NUMJOBS} \
+ release \
+ debug-symbols=none \
+ optimization=off \
+ --prefix="${D}/usr" \
+ --layout=system || die "building tools failed"
+ fi
+}
+
+src_install () {
+
+ generate_options
+
+ BOOST_ROOT=${S}
+ BOOST_BUILD_PATH=${ROOT}/usr/share/boost-build
+
+ for linkoption in ${LINK_OPTIONS} ; do
+ bjam \
+ ${OPTIONS} \
+ runtime-link=${linkoption} link=${linkoption} \
+ --prefix="${D}/usr" \
+ --includedir="${D}/usr/include" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ --layout=system \
+ install || die "install failed"
+ done
+
+ dodoc README
+
+ if use doc ; then
+ dohtml -A .pdf,.txt \
+ *.htm *.gif *.css \
+ -r doc libs more people wiki
+ fi
+
+ cd "${D}/usr/$(get_libdir)"
+
+ for lib in $(ls -1 libboost_thread-mt.*) ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_install
+ fi
+
+ if use tools; then
+ cd "${S}/dist"
+ dobin bin/*
+ insinto /usr
+ doins -r share
+ fi
+
+}
diff --git a/dev-libs/boost/files/digest-boost-1.34_pre20061214 b/dev-libs/boost/files/digest-boost-1.34_pre20061214
new file mode 100644
index 000000000000..ed25c5f3af30
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.34_pre20061214
@@ -0,0 +1,3 @@
+MD5 c2ecc5f9f12198eb7fe116a14edd65a5 boost_1_34_pre20061214.tar.bz2 12357020
+RMD160 51a96ef3dc28b4bd1d5fc3c295a4a3f874fe59fa boost_1_34_pre20061214.tar.bz2 12357020
+SHA256 4c88805afe6b47366d960d878eec8a6e0e7f40a7f9122a7d877020e9102d0e49 boost_1_34_pre20061214.tar.bz2 12357020
diff --git a/dev-libs/boost/files/random-Jamfile b/dev-libs/boost/files/random-Jamfile
new file mode 100644
index 000000000000..5cb6f6bcd9be
--- /dev/null
+++ b/dev-libs/boost/files/random-Jamfile
@@ -0,0 +1,15 @@
+# Copyright (c) 2006 Tiziano Mueller
+#
+# Use, modification and distribution of the file is subject to the
+# Boost Software License, Version 1.0.
+# (See at http://www.boost.org/LICENSE_1_0.txt)
+
+
+project boost/random
+ : source-location ../ ;
+
+SOURCES = random_device ;
+
+lib boost_random
+ : $(SOURCES).cpp
+ : <link>shared:<define>BOOST_RANDOM_DYN_LINK=1 ;