summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-14 14:27:31 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-14 14:27:31 +0000
commit00a0fa8334c62c4121d67287bba89728f4fc4caf (patch)
tree26496f46df665773b38d5e76fff76cbbc267d053 /dev-libs/bitset
parentStable on amd64 and arm, wrt bug #457236 (diff)
downloadgentoo-2-00a0fa8334c62c4121d67287bba89728f4fc4caf.tar.gz
gentoo-2-00a0fa8334c62c4121d67287bba89728f4fc4caf.tar.bz2
gentoo-2-00a0fa8334c62c4121d67287bba89728f4fc4caf.zip
Version bump, wrt bug #457204, thanks to Johan Bergström
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/bitset')
-rw-r--r--dev-libs/bitset/ChangeLog9
-rw-r--r--dev-libs/bitset/bitset-2.8.2.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-libs/bitset/ChangeLog b/dev-libs/bitset/ChangeLog
index 41677ea88f91..5a50bd369278 100644
--- a/dev-libs/bitset/ChangeLog
+++ b/dev-libs/bitset/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/bitset
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.1 2012/12/05 03:58:24 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.2 2013/02/14 14:27:31 pinkbyte Exp $
+
+*bitset-2.8.2 (14 Feb 2013)
+
+ 14 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +bitset-2.8.2.ebuild:
+ Version bump, wrt bug #457204, thanks to Johan Bergström
*bitset-2.8.1 (05 Dec 2012)
diff --git a/dev-libs/bitset/bitset-2.8.2.ebuild b/dev-libs/bitset/bitset-2.8.2.ebuild
new file mode 100644
index 000000000000..25ca1f97e1b3
--- /dev/null
+++ b/dev-libs/bitset/bitset-2.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.2.ebuild,v 1.1 2013/02/14 14:27:31 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
+HOMEPAGE="http://github.com/chriso/bitset"
+SRC_URI="https://github.com/chriso/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="jemalloc static-libs tcmalloc"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="?? ( jemalloc tcmalloc )"
+
+DOCS=( README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with jemalloc) \
+ $(use_with tcmalloc)
+ )
+ autotools-utils_src_configure
+}