summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-05 03:58:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-05 03:58:24 +0000
commit15c3f83a0441a603c2d658861f6515118513b695 (patch)
tree803924eda5fc63a263e38b1baba4a36b2a8283b9 /dev-libs/bitset/bitset-2.8.1.ebuild
parentRemove temp Qt 4.8.4 mask (diff)
downloadgentoo-2-15c3f83a0441a603c2d658861f6515118513b695.tar.gz
gentoo-2-15c3f83a0441a603c2d658861f6515118513b695.tar.bz2
gentoo-2-15c3f83a0441a603c2d658861f6515118513b695.zip
Initial commit wrt bug #445880. Ebuild by Johan Bergström. He will maintain this package through proxy maintainers
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/bitset/bitset-2.8.1.ebuild')
-rw-r--r--dev-libs/bitset/bitset-2.8.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/bitset/bitset-2.8.1.ebuild b/dev-libs/bitset/bitset-2.8.1.ebuild
new file mode 100644
index 000000000000..cda522f28676
--- /dev/null
+++ b/dev-libs/bitset/bitset-2.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.1.ebuild,v 1.1 2012/12/05 03:58:24 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
+HOMEPAGE="http://github.com/chriso/bitset"
+SRC_URI="mirror://github/chriso/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="jemalloc static-libs tcmalloc"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="tcmalloc? ( !jemalloc )
+ jemalloc? ( !tcmalloc )"
+
+DOCS=( README.md )
+
+src_configure() {
+ econf \
+ $(use_with jemalloc) \
+ $(use_with tcmalloc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}